1

I have a shiny new Lenovo P14s 2nd gen ( installed with dual boot, Win10 and… ) Ubuntu MATE 20.04.2 LTS. And I can't connect by Wi-Fi. For some graphics-related driver issues (a little too shiny new after all for Ubuntu 20.04 it seemed) I did upgrade the kernel to 5.12.4 generic, but this is probably not relevanthere.

I can't see any network connections. Neither in the top panel (where a respective pulldown would sit in the Notification area with the well-known wifi waves-symbol) nor in the control-center (like I do under my old 16.04 machine, where there was a „Network Connections“ with all the nearby Wifi's to choose from) from. Here, it's missing:

(the usual rest is there, but nothing on “Network Connections”...)

enter image description here

I first suspected that also my Wifi adapter might be 'too' new and needs drivers… However I a) installed some drivers follwoing Lenovo documents and b) also plugged in a truly simple (3-4 year-old) USB LogiLink-Wifi adapter – no luck, no wifi connections offered anywhere.

inxi -N says, it's all there!

$> inxi -N
Network:    Device-1: Intel Ethernet I219-V driver: e1000e
            Device-2: Intel driver: iwlwifi
            Device-3: Ralink RT5370 Wireless Adapter type: USB driver: rt2800usb
            Device-4: Lenovo USB3.1 Hub type: USB driver: r8152

…and so does iwconfig. The wlx... one must be the external one (simple plug-in-plug-out test). I am not a driver/hardware expert, but looks to me like both devices are recognized and even operational (even with Bit Rate and Quality measuring under way...)

lo        no wireless extensions.
enp0s31f6  no wireless extensions.
enx083a885b1fdf  no wireless extensions.
wlp9s0    IEEE 802.11  ESSID:"WN-62F2C0"
      Mode:Managed  Frequency:5.54 GHz  Access Point: 7C:<redacted>:C5
      Bit Rate=866.7 Mb/s   Tx-Power=22 dBm
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:on
      Link Quality=69/70  Signal level=-41 dBm
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:63   Missed beacon:0
docker0   no wireless extensions.
wlx7cdd9017b62f  IEEE 802.11  ESSID:off/any
        Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm
        Retry short  long limit:2   RTS thr:off   Fragment thr:off
        Power Management:off

$> dpkg -l | grep -i "network.*manager"

ii libnm0:amd64                          1.22.10-1ubuntu2.2 amd64 GObject-based client library for NetworkManager
ii libproxy1-plugin-networkmanager:amd64 0.4.15-10ubuntu1.2 amd64 automatic proxy configuration management library (Network Manager plugin)
ii network-manager                       1.22.10-1ubuntu2.2 amd64 network management framework (daemon and userspace tools)
ii network-manager-gnome                 1.8.24-1ubuntu3    amd64 network management framework (GNOME frontend)
ii network-manager-openvpn               1.8.12-1           amd64 network management framework (OpenVPN plugin core)
ii network-manager-openvpn-gnome         1.8.12-1           amd64 network management framework (OpenVPN plugin GNOME GUI)
ii network-manager-pptp                  1.2.8-2            amd64 network management framework (PPTP plugin core)
ii network-manager-pptp-gnome            1.2.8-2            amd64 network management framework (PPTP plugin GNOME GUI)

I am really clueless... thank you for your help!

6
  • Have you tried to run nm-applet manually? Please also add output of dpkg -l | grep -i "network.*manager" to the question. – N0rbert Jun 17 at 19:12
  • @N0rbert I can start nm-applet (it will run, I can also then kill it again and repeat…), but nothing pops up or shows up in any panel. Added dpkg… output above. – Frank Nocke Jun 17 at 19:40
  • On package level all is ok. Maybe MATE Panel layout was broken in some way. You can launch MATE Tweak and then switch Panel layout to for example Traditional. Also try to run nmtui to setup Wi-Fi connection for first time. – N0rbert Jun 17 at 20:10
  • @N0rbert Sadly, resetting and choosing different panels is not helping, all those other layouts have the ↑↓-Symbol left of the battery gauge, but I don't. I must have messed up something more badly during install... – Frank Nocke Jun 19 at 18:50
  • 1
    Maybe it is overkill, but you can try to reinstall all MATE indicators by sudo apt-get install --reinstall a11y-profile-manager-indicator gir1.2-appindicator3-0.1 indicator-application indicator-common indicator-datetime indicator-messages indicator-notifications indicator-power indicator-session indicator-sound libappindicator3-1 libindicator3-7 mate-indicator-applet mate-indicator-applet-common and NetworkManager by sudo apt-get install --reinstall network-manager-gnome network-manager mate-themes ubuntu-mate-default-settings . Then reboot and try to switch MATE Panel layouts again. – N0rbert Jun 19 at 18:54
1

I did another attempt (with no significant changes anywhere) to add the indicator applet. Now I got it including all I wanted, also the crucial ↑↓ bit (the nm-applet aka networkmanager, afaik). Including pulldown, enabling, choosing, disabling Wifi-Connections...

Yeah, computer “science”...

enter image description here

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.