44

Is there a way you can disable or customize the notification bubbles on Lucid?

alt text

1
  • 1
    N.B. With rhythmbox's notifications on which songs are playing, disable the Notification plugin.
    – Wilf
    Commented Apr 5, 2015 at 11:47

9 Answers 9

22

Yes you can, using a tool called Notify OSD Configuration.

If you want to disable them rename the file
/usr/share/dbus-1/services/org.freedesktop.Notifications.service:

sudo mv /usr/share/dbus-1/services/org.freedesktop.Notifications.service{,.disabled}

To re-enable:

sudo mv /usr/share/dbus-1/services/org.freedesktop.Notifications.service{.disabled,}

You need to restart your computer after either one of these changes for them to take effect.

7
  • This tool presume that you patch your original notify ost libraries, and you cannot disable them. I wouldn't recommend this.
    – OpenNingia
    Commented Nov 16, 2010 at 12:46
  • @OpenNingia, using a patched NotifyOSD is necessary because the default doesn't allow any configuration. Edited my answer to show how to disable them entirely.
    – Isaiah
    Commented Nov 16, 2010 at 18:04
  • This didn't work for me on Ubuntu 12.04. I executed your first command and then promptly received a notification seconds later from Spotify. Commented May 30, 2014 at 2:11
  • 10
    wooow, I'm not sure if that worked, but that syntax you're using in mv will change my life forever. Commented Aug 19, 2015 at 13:52
  • 1
    Restarting the computer is never the correct way to activate, enable, shut down or disable a service on Linux.
    – Teekin
    Commented Mar 18, 2018 at 22:13
8

To alter these settings, install gconf-editor from the software-center.

Scroll to / ▸ apps ▸ nm-applet and check disable-connected-notifications and disable-disconnected-notifications settings there. Check the attached image for clarifications.

enter image description here

As For the VLC, you need to visit VLC Preferences (Press Ctrl + P, or access it from tools Menu)

And Disable SysTray Popup when Minimized (Hover the move over that option and read the descripton)

enter image description here

1
  • 2
    I was searching how to turn them off in vlc. Thanks!
    – s3v3n
    Commented Apr 24, 2014 at 10:09
6

You can also turn off particular notification.To turn off pidgin notification,Open pidgin-->Tools--->Plugins

Uncheck libnotify popups there..

alt text

To turn off notify-osd notifications,type the following in terminal and restart your system.

sudo mv /usr/share/dbus-1/services/org.freedesktop.Notifications.service /usr/share/dbus-1/services/org.freedesktop.Notifications.service.disabled

To disable rythmbox song pop up notification:

Go to:

Edit -> Plugins

and uncheck the Status Icon plugin.

Another way:

Edit --> Plugins

Select Status Icon, click the configure button

Choose the never shown option for notifications.

1
  • Thanks. However, the one piece of software I would really want to disable notifications for is Banshee, but there doesn't seem to be any options for that at all, unless I'm really missing something.
    – Mussnoon
    Commented Nov 18, 2010 at 16:07
4

You can stop song change popup notification form this

  1. Open Rhythmbox see in Menu: Edit -> Plagins (open it)
  2. Uncheck Notification plugin

Image Link

2

The question

How to turn off the pop up notification in 12.04?

was redirected here but this question's context is framed for lucid 10.04 which uses notification-daemon and not Pangolin 12.04 which uses notify-osd (On Screen Display) to make pop-up bubbles.

This can be seen in the 12.04 system file (NB 10.04 predates this):

view-source:file:///usr/share/dbus-1/services/org.freedesktop.Notifications.service

with notifying content uniquely specific to either the Unity or Gnome default interface:

[D-BUS Service]
Name=org.freedesktop.Notifications
Exec=/bin/sh -c 'if
     [ ! -x /usr/lib/notification-daemon/notification-daemon ] ||
     [ "$GDMSESSION" = guest-restricted ] ||
     [ "$GDMSESSION" = gnome-classic-guest-restricted ]
     [ "$GDMSESSION" = default -a
          "$(basename `readlink /etc/alternatives/x-session-manager`)" =
                gnome-session ] ||
     [ "$GDMSESSION" = ubuntu ] ||
     [ "$GDMSESSION" = ubuntu-2d ];
  then exec /usr/lib/notify-osd/notify-osd;
  else exec /usr/lib/notification-daemon/notification-daemon; fi'

What follows is explicitly for the 12.04 redirected question.

The complete stack of pending notifications can be disabled and cleared using a terminal window
(Ctrl+Alt+T) and entering

killall notify-osd

after which notifications resume.

To disable for an arbitrary length of time use:

dbus-monitor "interface='org.freedesktop.Notifications'" |             \
grep --line-buffered "member=Notify"                     |             \
sed -u -e  's/.*/killall notify-osd/g'                   |             \
bash

This crude solution can be stopped by closing the terminal window or typing Ctrl+C.

Change "member=Notify" to customize the desired selection of notifications for purging.

For more control see:
Can org.freedesktop.Notifications.CloseNotification(uint id) be triggered and invoked via DBus?

Other techniques are documented in the references.

ref.:

1

This script toggles the notify-osd notifications: (inspired by https://askubuntu.com/a/35840/17940)

$ cat toggle-notify.sh

# Disable libnotify notification bubbles that appear in the top-right corner
# of your screen. Works on Ubuntu 12.04.
disabled=$HOME/notify-osd-disabled
if [ -e $disabled ]
then
  echo "Enabled notify-osd"
  sudo chmod +x /usr/lib/notify-osd/notify-osd
  rm -f $disabled
else
  echo "Disabled notify-osd"
  sudo chmod -x /usr/lib/notify-osd/notify-osd
  killall notify-osd 2>/dev/null
  touch $disabled
fi

It works on:

  • Ubuntu 12.04
  • Ubuntu 14.04

Make it executable and run it:

$ chmod +x toggle-notify.sh

$ ./toggle-notify.sh 
Disabled notify-osd

Keyboard shortcut

You can bind a keyboard shortcut to this script:

$ mkdir ~/bin
$ mv toggle-notify.sh ~/bin
$ export PATH="$HOME/bin:$PATH"

enter image description here

0

To disable the Notification bubbles you can remove the 'Notification Area' item from the panel. Just right click on the notification area item and select 'Remove From Panel'.

UPDATE: The Notification Area will be no more from Ubuntu 11.04

1
  • I don't want to get rid of the notification area entirely, but only the bubbles.
    – Mussnoon
    Commented Nov 16, 2010 at 6:31
0

go to package manager and remove pop-up notification ;; it will auto install another that the system needs .BUT will not show a pop-up window when a new song comes on . did this to mine mint 16 mate.

0

I have tried all of the methods listed here, and none worked in Fedora 18. Eventually I found something that worked (copy-pasted from http://www.superuser.com/questions/543064/how-to-disable-all-gnome-3-notifications):


I have several systems from which I don't want update or other messages. I would prefer to just check logs.

Unless you want to go into each program (i.e. Network settings » Disable Notifications), yet still get system messages, you could:

su -
chmod 000 /usr/libexec/notification-daemon
reboot

This should work on most GNOME3 systems to kill all messages.


Hope it saves someone hours of searching.

2
  • why Fedora on AskUbuntu? Why Fedora18, when it is EOL?
    – Jakuje
    Commented Jan 20, 2016 at 22:02
  • I found no thread on the internet asking this question for anything outside of Ubuntu, other than the one I referenced. I think the same behavior should occur on other versions of Fedora also; I just put 18 because that's what I have.
    – Alex
    Commented Jan 22, 2016 at 21:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .