Recently, my Ubuntu 20.04 LTS has been unable to extract any sort of ZIP files, it will always get stuck on "Verifying Destination" on the GUI, see here: GUI of the error

I tried running nautilus through the command line to see what was going on, and it spits out the following line of codes hundreds of times before inevitably crashing: Terminal output

I've created ZIP files of my own of varying sizes as well as downloading various ones from online; regardless of the contents, size, or creation source, extracting the files simply does not work, and nautilus will crash after a few minutes of idling.

Trying to extract a zip through the command line using unzip will give the following error: unzip terminal error (note that the files are never extracted)

However, extracting a tar.xz file works fine, and if I simply drag the files out of archine manager and into a folder, the files end up there without a hitch. This is not a huge inconvinience but I'm very curious as to why this happening, and would also appreciate a fix. So far, I've tried restarting my computer, restarting nautilus, removing and reinstalling nautilus, removing and reinstalling ubuntu-desktop, removing and reinstalling unzip.

  • You seem to like using sudo: perhaps some permissions in your user configuration are not anymore correct. You could temporarily create a new user, see if the issue persists in a fresh account. If not, then you know it is some damage in your user configuration. If yes, then it is a system wide issue.
    – vanadium
    Jun 15, 2021 at 6:46

2 Answers 2


For anyone coming across this in the future, it seems to have been an issue with the kernel. I swapped to an older kernel and now unzipping works fine.


I faced the same problem today.

Despite not being able to find a solution when right clicking and pressing extract, I managed to find an alternative method by left clicking on the zip file and extracting the files by pressing the Extract button as shown in the image attached . You will also need to create a new folder where the extracted files will be placed.

Hope this provides an alternative method if you do not want to switch to an older kernel!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .