0

What is going on with this failed upgrade attempt ? The system is currently fully up to date with aptitude full-upgrade

$ sudo do-release-upgrade 
Checking for a new Ubuntu release
Get:1 Upgrade tool signature [819 B]                                                                                                                                
Get:2 Upgrade tool [1,276 kB]                                                                                                                                       
Fetched 1,276 kB in 0s (0 B/s)                                                                                                                                      
authenticate 'hirsute.tar.gz' against 'hirsute.tar.gz.gpg' 
extracting 'hirsute.tar.gz'

Reading cache

Checking package manager
Reading package lists... Done
Building dependency tree        
Reading state information... Done
Hit http://archive.ubuntu.com/ubuntu groovy InRelease                                                                                                               
Get:1 http://archive.ubuntu.com/ubuntu groovy-updates InRelease [115 kB]                                                                                            
Get:2 http://archive.ubuntu.com/ubuntu groovy-backports InRelease [101 kB]                                                                                          
Get:3 http://archive.ubuntu.com/ubuntu groovy-security InRelease [110 kB]                                                                                           
Fetched 326 kB in 0s (0 B/s)                                                                                                                                        
Reading package lists... Done    
Building dependency tree          
Reading state information... Done

Checking for installed snaps

Calculating snap size requirements
No candidate ver:  akonadi-contacts-data
No candidate ver:  akonadi-mime-data
...400 lines like that...
No candidate ver:  vlc-nox
No candidate ver:  xfonts-mathml

Updating repository information
Get:1 http://archive.ubuntu.com/ubuntu hirsute InRelease [269 kB]                                                                                                   
Get:2 http://archive.ubuntu.com/ubuntu hirsute-updates InRelease [109 kB]                                                                                           
...
Get:110 http://archive.ubuntu.com/ubuntu hirsute-security/multiverse Translation-en [432 B]                                                                         
Get:111 http://archive.ubuntu.com/ubuntu hirsute-security/multiverse amd64 c-n-f Metadata [116 B]                                                                   
Fetched 184 MB in 6s (1,884 kB/s)                                                                                                                                   

Checking package manager
Reading package lists... Done    
Building dependency tree          
Reading state information... Done

Calculating the changes

Calculating the changes

Could not calculate the upgrade 

An unresolvable problem occurred while calculating the upgrade. 

If none of this applies, then please report this bug using the 
command 'ubuntu-bug ubuntu-release-upgrader-core' in a terminal. If 
you want to investigate this yourself the log files in 
'/var/log/dist-upgrade' will contain details about the upgrade. 
Specifically, look at 'main.log' and 'apt.log'. 


Restoring original system state

Aborting
Reading package lists... Done    
Building dependency tree          
Reading state information... Done


$ cat /var/log/dist-upgrade/main.log     
2021-06-14 23:25:41,964 INFO Using config files '['./DistUpgrade.cfg', '/etc/update-manager/release-upgrades.d/ubuntu-advantage-upgrades.cfg', '/etc/update-manager/release-upgrades.d/neon.cfg']'
2021-06-14 23:25:41,964 INFO uname information: 'Linux antar 5.8.0-55-generic #62-Ubuntu SMP Tue Jun 1 08:21:18 UTC 2021 x86_64'
2021-06-14 23:25:42,407 INFO apt version: '2.1.10ubuntu0.3'
2021-06-14 23:25:42,407 INFO python version: '3.8.6 (default, May 27 2021, 13:28:02) 
[GCC 10.2.0]'
2021-06-14 23:25:42,409 INFO release-upgrader version '21.04.13' started
2021-06-14 23:25:42,419 INFO locale: 'en_SE' 'UTF-8'
2021-06-14 23:25:42,464 INFO screen could not be run
2021-06-14 23:25:42,519 DEBUG Using 'DistUpgradeViewText' view
2021-06-14 23:25:42,567 DEBUG enable dpkg --force-overwrite
2021-06-14 23:25:42,602 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
2021-06-14 23:25:48,873 DEBUG lsb-release: 'groovy'
2021-06-14 23:25:48,874 DEBUG _pythonSymlinkCheck run
2021-06-14 23:25:48,875 DEBUG openCache()
2021-06-14 23:25:48,875 DEBUG quirks: running PreCacheOpen
2021-06-14 23:25:48,875 DEBUG running Quirks.PreCacheOpen
2021-06-14 23:25:49,653 DEBUG Comparing 5.8.0-50 with 
2021-06-14 23:25:49,653 DEBUG Comparing 5.8.0-55 with 5.8.0-50
2021-06-14 23:25:49,833 DEBUG /openCache(), new cache size 68613
2021-06-14 23:25:49,834 DEBUG need_server_mode(): can not find a desktop meta package or key deps, running in server mode
2021-06-14 23:25:49,834 DEBUG checkViewDepends()
2021-06-14 23:25:49,838 DEBUG running doUpdate() (showErrors=False)
2021-06-14 23:25:52,426 DEBUG openCache()
2021-06-14 23:25:53,202 DEBUG Comparing 5.8.0-50 with 
2021-06-14 23:25:53,202 DEBUG Comparing 5.8.0-55 with 5.8.0-50
2021-06-14 23:25:53,329 DEBUG /openCache(), new cache size 68613
2021-06-14 23:25:53,330 DEBUG doPostInitialUpdate
2021-06-14 23:25:53,330 DEBUG quirks: running hirsutePostInitialUpdate
2021-06-14 23:25:53,330 DEBUG running Quirks.hirsutePostInitialUpdate
2021-06-14 23:25:55,104 DEBUG Snap audio-recorder is installed
2021-06-14 23:25:55,104 DEBUG Snap audio-recorder is not tracking the release channel
2021-06-14 23:25:55,362 DEBUG Snap core18 is installed
2021-06-14 23:25:55,362 DEBUG Snap core18 is not tracking the release channel
2021-06-14 23:25:55,625 DEBUG Snap fontvuer is installed
2021-06-14 23:25:55,625 DEBUG Snap fontvuer is not tracking the release channel
2021-06-14 23:25:55,794 DEBUG Snap gnome-3-28-1804 is installed
2021-06-14 23:25:55,794 DEBUG Snap gnome-3-28-1804 is not tracking the release channel
2021-06-14 23:25:55,989 DEBUG Snap gtk-common-themes is installed
2021-06-14 23:25:55,989 DEBUG Snap gtk-common-themes is not tracking the release channel
2021-06-14 23:25:56,140 DEBUG Snap shotcut is installed
2021-06-14 23:25:56,140 DEBUG Snap shotcut is not tracking the release channel
2021-06-14 23:25:56,301 DEBUG Snap snapd is installed
2021-06-14 23:25:56,301 DEBUG Snap snapd is not tracking the release channel
2021-06-14 23:25:57,480 DEBUG MetaPkgs: 
2021-06-14 23:26:03,159 DEBUG no PkgRecord found for 'akonadi-contacts-data', skipping 
2021-06-14 23:26:03,159 DEBUG no PkgRecord found for 'akonadi-mime-data', skipping 
...
2021-06-14 23:26:04,361 DEBUG no PkgRecord found for 'vlc-nox', skipping 
2021-06-14 23:26:04,382 DEBUG no PkgRecord found for 'xfonts-mathml', skipping 
2021-06-14 23:26:04,398 DEBUG Foreign: 
2021-06-14 23:26:04,398 DEBUG Obsolete: amarok-common banish404 clang-6.0 clang-7 cnijfilter-common cnijfilter-ip2800series cpp-5 drkonqi-pk-debug-installer fvd-module gcc-5 gcc-5-base gimp-plugin-userfilter:i386 google-chrome-stable google-earth-pro-stable ippusbxd kde-runtime-data kdelibs5-data libasan2 libavcodec57 libavformat57 libavutil55 libboost-date-time1.67.0 libboost-filesystem1.67.0 libboost-iostreams1.67.0 libboost-locale1.67.0 libboost-system1.67.0 libboost-thread1.67.0 libcdio18 libcfitsio5 libcfitsio8 libclang-common-6.0-dev libclang-common-7-dev libclang1-6.0 libclang1-7 libcloog-isl4 libdc1394-22 libdouble-conversion1 libdvdcss-dev libdvdcss2 libebml4v5 libffi7 libfreerdp-cache1.1 libfreerdp-client1.1 libfreerdp-codec1.1 libfreerdp-common1.1.0 libfreerdp-core1.1 libfreerdp-crypto1.1 libfreerdp-gdi1.1 libfreerdp-locale1.1 libfreerdp-plugins-standard libfreerdp-primitives1.1 libfreerdp-rail1.1 libfreerdp-utils1.1 libgcc-5-dev libgit2-26 libhavege1 libhttp-parser2.7.1 libhunspell-1.6-0 libicu60 libicu66 libilmbase12 libisl15 libjavascriptcoregtk-3.0-0 libkaccounts1 libkf5libkdepimakonadi5 libkf5texteditor5-libjs-underscore libkf5torrent6 libkonq5-templates libllvm6.0 libllvm7 libmatroska6v5 libmpx0 libmysqlclient20 libntdb1 libntrack0 libopenexr22 libparse-debianchangelog-perl libpipewire-0.2-1 libplacebo7 libprotobuf-lite17 libprotobuf17 libqrencode3 libraw16 libre2-5 libservlet3.0-java libssl1.0.0 libswresample2 libtidy-0.99-0 libtinyxml2-6a libvpx1 libvpx5 libwebkitgtk-3.0-0 libwinpr-crt0.1 libwinpr-dsparse0.1 libwinpr-environment0.1 libwinpr-file0.1 libwinpr-handle0.1 libwinpr-heap0.1 libwinpr-input0.1 libwinpr-interlocked0.1 libwinpr-library0.1 libwinpr-path0.1 libwinpr-pool0.1 libwinpr-registry0.1 libwinpr-rpc0.1 libwinpr-sspi0.1 libwinpr-synch0.1 libwinpr-sysinfo0.1 libwinpr-thread0.1 libwinpr-utils0.1 libx264-152 libx264-155 libx265-146 libxfreerdp-client1.1 libzip4 llvm-6.0 llvm-6.0-dev llvm-6.0-runtime llvm-7 llvm-7-dev llvm-7-runtime multiarch-support ntrack-module-libnl-0 python-apt python-attr python-cffi-backend python-characteristic python-crypto python-cryptography python-dateutil python-dbus python-dnspython python-enum34 python-gi python-gobject python-gobject-2 python-httplib2 python-idna python-ipaddress python-mako python-openssl python-pyasn1 python-pyasn1-modules python-pyparsing python-service-identity python-sip python-talloc python-yaml python-zope.interface syslinux-legacy ttf-dejavu-core x11proto-damage-dev x11proto-fixes-dev xserver-xorg-video-intel-arbiter zoom
2021-06-14 23:26:04,398 DEBUG updateSourcesList()
2021-06-14 23:26:04,407 DEBUG rewriteSourcesList() with mirror_check
2021-06-14 23:26:04,408 DEBUG ['ubuntu-minimal', 'ubuntu-standard']
2021-06-14 23:26:04,408 DEBUG Checking pkg: ubuntu-minimal
2021-06-14 23:26:04,410 DEBUG Checking pkg: ubuntu-standard
2021-06-14 23:26:04,414 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy main restricted'
2021-06-14 23:26:04,415 DEBUG verifySourcesListEntry: deb http://archive.ubuntu.com/ubuntu hirsute main restricted
2021-06-14 23:26:04,415 DEBUG url_downloadable: http://archive.ubuntu.com/ubuntu/dists/hirsute/Release
2021-06-14 23:26:04,415 DEBUG s='http' n='archive.ubuntu.com' p='/ubuntu/dists/hirsute/Release' q='' f=''
2021-06-14 23:26:04,469 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute main restricted' updated to new dist
2021-06-14 23:26:04,469 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy main restricted'
2021-06-14 23:26:04,469 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute main restricted' updated to new dist
2021-06-14 23:26:04,470 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy-updates main restricted'
2021-06-14 23:26:04,470 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute-updates main restricted' updated to new dist
2021-06-14 23:26:04,470 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy-updates main restricted'
2021-06-14 23:26:04,470 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute-updates main restricted' updated to new dist
2021-06-14 23:26:04,470 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy universe'
2021-06-14 23:26:04,470 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute universe' updated to new dist
2021-06-14 23:26:04,470 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy universe'
2021-06-14 23:26:04,470 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute universe' updated to new dist
2021-06-14 23:26:04,470 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy-updates universe'
2021-06-14 23:26:04,470 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute-updates universe' updated to new dist
2021-06-14 23:26:04,470 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy-updates universe'
2021-06-14 23:26:04,470 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute-updates universe' updated to new dist
2021-06-14 23:26:04,470 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy multiverse'
2021-06-14 23:26:04,470 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute multiverse' updated to new dist
2021-06-14 23:26:04,470 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy multiverse'
2021-06-14 23:26:04,470 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute multiverse' updated to new dist
2021-06-14 23:26:04,471 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy-updates multiverse'
2021-06-14 23:26:04,471 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute-updates multiverse' updated to new dist
2021-06-14 23:26:04,471 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy-updates multiverse'
2021-06-14 23:26:04,471 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute-updates multiverse' updated to new dist
2021-06-14 23:26:04,471 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy-backports main restricted universe multiverse'
2021-06-14 23:26:04,471 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute-backports main restricted universe multiverse' updated to new dist
2021-06-14 23:26:04,471 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy-backports main restricted universe multiverse'
2021-06-14 23:26:04,471 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute-backports main restricted universe multiverse' updated to new dist
2021-06-14 23:26:04,471 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy-security main restricted'
2021-06-14 23:26:04,471 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute-security main restricted' updated to new dist
2021-06-14 23:26:04,471 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy-security main restricted'
2021-06-14 23:26:04,471 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute-security main restricted' updated to new dist
2021-06-14 23:26:04,471 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy-security universe'
2021-06-14 23:26:04,471 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute-security universe' updated to new dist
2021-06-14 23:26:04,471 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy-security universe'
2021-06-14 23:26:04,471 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute-security universe' updated to new dist
2021-06-14 23:26:04,471 DEBUG examining: 'deb http://archive.ubuntu.com/ubuntu groovy-security multiverse'
2021-06-14 23:26:04,472 DEBUG entry 'deb http://archive.ubuntu.com/ubuntu hirsute-security multiverse' updated to new dist
2021-06-14 23:26:04,472 DEBUG examining: 'deb-src http://archive.ubuntu.com/ubuntu groovy-security multiverse'
2021-06-14 23:26:04,472 DEBUG entry 'deb-src http://archive.ubuntu.com/ubuntu hirsute-security multiverse' updated to new dist
2021-06-14 23:26:04,474 DEBUG running doUpdate() (showErrors=True)
2021-06-14 23:27:32,408 DEBUG openCache()
2021-06-14 23:27:33,222 DEBUG Comparing 5.8.0-50 with 
2021-06-14 23:27:33,222 DEBUG Comparing 5.8.0-55 with 5.8.0-50
2021-06-14 23:27:33,329 DEBUG /openCache(), new cache size 69997
2021-06-14 23:27:33,330 DEBUG need_server_mode(): can not find a desktop meta package or key deps, running in server mode
2021-06-14 23:27:33,330 DEBUG quirks: running PreDistUpgradeCache
2021-06-14 23:27:33,330 DEBUG running Quirks.PreDistUpgradeCache
2021-06-14 23:27:33,330 INFO checking for python-dbg (auto_inst=False)
2021-06-14 23:27:33,330 INFO checking for python-doc (auto_inst=False)
2021-06-14 23:27:33,330 INFO checking for python-minimal (auto_inst=False)
2021-06-14 23:27:33,331 INFO checking for python-dev (auto_inst=False)
2021-06-14 23:27:33,331 INFO checking for libpython-dev (auto_inst=False)
2021-06-14 23:27:33,331 INFO checking for libpython-stdlib (auto_inst=False)
2021-06-14 23:27:33,331 INFO checking for libpython-dbg (auto_inst=False)
2021-06-14 23:27:33,331 INFO checking for python-dbg (auto_inst=True)
2021-06-14 23:27:33,331 INFO checking for python-doc (auto_inst=True)
2021-06-14 23:27:33,331 INFO checking for python-minimal (auto_inst=True)
2021-06-14 23:27:33,331 INFO checking for python-dev (auto_inst=True)
2021-06-14 23:27:33,331 INFO checking for libpython-dev (auto_inst=True)
2021-06-14 23:27:33,331 INFO checking for libpython-stdlib (auto_inst=True)
2021-06-14 23:27:33,331 INFO checking for libpython-dbg (auto_inst=True)
2021-06-14 23:27:35,786 DEBUG Running KeepInstalledSection rules
2021-06-14 23:27:36,427 DEBUG Kernel uname: '5.8.0-55-generic' 
2021-06-14 23:27:36,440 DEBUG nvidiaUpdate()
2021-06-14 23:27:37,369 INFO no old nvidia driver installed, installing no new
2021-06-14 23:27:37,370 DEBUG quirks: running PostDistUpgradeCache
2021-06-14 23:27:37,370 DEBUG running Quirks.PostDistUpgradeCache
2021-06-14 23:27:37,577 DEBUG Comparing 5.11.0-18 with 
2021-06-14 23:27:37,578 DEBUG Comparing 5.8.0-50 with 5.11.0-18
2021-06-14 23:27:37,578 DEBUG Comparing 5.8.0-55 with 5.11.0-18
2021-06-14 23:27:37,781 DEBUG blacklist expr 'kubuntu-desktop' matches 'kubuntu-desktop'
2021-06-14 23:27:37,781 DEBUG The package 'kubuntu-desktop' is marked for removal but it's in the removal blacklist
2021-06-14 23:27:37,811 ERROR Dist-upgrade failed: 'The package 'kubuntu-desktop' is marked for removal but it is in the removal blacklist.'
2021-06-14 23:27:37,811 DEBUG abort called
2021-06-14 23:27:37,813 DEBUG openCache()
2021-06-14 23:27:40,102 DEBUG Comparing 5.8.0-50 with 
2021-06-14 23:27:40,102 DEBUG Comparing 5.8.0-55 with 5.8.0-50
2021-06-14 23:27:40,241 DEBUG /openCache(), new cache size 68613
dargaud@antar:/tmp

$ cat /var/log/dist-upgrade/apt.log 
Starting pkgProblemResolver with broken count: 0
Starting 2 pkgProblemResolver with broken count: 0
Done
MarkInstall blender:amd64 < 2.83.5+dfsg-1build2 -> 2.83.5+dfsg-5build1 @ii umU Ib > FU=0
Installing libboost-locale1.74.0:amd64 as Depends of blender:amd64
    MarkInstall libboost-locale1.74.0:amd64 < none -> 1.74.0-8ubuntu2 @un uN Ib > FU=0
...a lot more stuff...
MarkDelete plasma-widgets-addons:amd64 < 4:5.19.5-0ubuntu1 | 4:5.21.4-0ubuntu1 @ii umH Ib > FU=0
Investigating (3) kubuntu-settings-desktop:amd64 < 1:20.10.1 -> 1:21.04.5 @ii umU Ib >
Broken kubuntu-settings-desktop:amd64 Depends on plasma-workspace:amd64 < 4:5.19.5-0ubuntu2 @ii mR > (>= 4:5.18.0~)
Considering plasma-workspace:amd64 6542 as a solution to kubuntu-settings-desktop:amd64 1
MarkKeep kubuntu-settings-desktop:amd64 < 1:20.10.1 -> 1:21.04.5 @ii umU Ib > FU=0
Removing kubuntu-settings-desktop:amd64 rather than change plasma-workspace:amd64
MarkDelete kubuntu-settings-desktop:amd64 < 1:20.10.1 | 1:21.04.5 @ii umH Ib > FU=0
Done
nvidia-driver-418
Log time: 2021-06-14 23:27:40.224004
5
  • What is your current version ? Please add the output of lsb_release -a to yout question.
    – Soren A
    Jun 14 at 23:13
  • 1
    @SorenA Appears to be 'groovy' 20.10 based on the output provided. Jun 14 at 23:14
  • Check inthe Softesre & updayes app under Settings -> Updates that "Notify me ..." is set to ",, any new vrsion" and NOT "long term support versions"
    – Soren A
    Jun 14 at 23:25
  • 3
    The problem seems clearly listed in your output: 2021-06-14 23:27:37,811 ERROR Dist-upgrade failed: 'The package 'kubuntu-desktop' is marked for removal but it is in the removal blacklist. This usually occurs when you muck about with desktop application packages....and that seems to be confirmed by your apt.log output. Your question should clearly explain what you did to muck up your desktop packages. Perhaps you were trying to install some wrong-version packages? Offering solutions is much easier when we understand the cause of the problem.
    – user535733
    Jun 15 at 0:55
  • Long ago I converted kubuntu to Neon, but then a few years later I reverted back (you can do that by changing a few repositories). Since then it's been running smoothly and I've gone through at least one or two do-release-upgrade, and I haven't done much since then, except trying without success to solve the problem of the missing 'switch user' option. Should I try to reinstall kubuntu-desktop or some similar action ?
    – dargaud
    Jun 15 at 11:59
1

I had no idea what the cause was, but I operated from the command line (ssh or Ctrl-Alt-F2) and simply did:

# aptitude remove kubuntu-desktop 
# do-release-upgrade
(reboot)
# aptitude install kubuntu-desktop

Everything seems fine now.

1
  • Good job figuring it out from your debug output!
    – user535733
    Jun 17 at 14:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.