I had Ubuntu 11.10 previously with no connection issues. I reformatted (I didn't upgrade) and installed Ubuntu 12.04.

Now web pages take a long time to start loading. When I visit google.com it can take up to 10 seconds before it starts loading. Once it starts loading, it loads very quickly. The same goes with all other websites.

I've tried several suggestions I've found online with no success.

I've tried disabling dnsmasq as suggested here: http://www.stgraber.org/2012/02/24/dns-in-ubuntu-12-04/

I've tried setting my DNS servers to google's open dns: and

Anyway, here is some info about my system:

$ cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
#NetworkManager#iface eth0 inet dhcp


$ nm-tool

- Device: eth0  [Wired connection 1] -------------------------------------------
  Type:              Wired
  Driver:            e1000e
  State:             connected
  Default:           yes
  HW Address:        5C:26:0A:1D:E6:57

    Carrier Detect:  yes
    Speed:           1000 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Prefix:          24 (

  • Is your Ubuntu install running as the guest in (VirtualBox?) VM? (If so, what OS is the host?) May 10, 2012 at 6:33

1 Answer 1


Ok I found my issue.

After using a VPN client (Network Connect), the /etc/resolv.conf symlink was replaced with an actual file. Some DNS servers were prepended to this file before my and dns servers. So, web pages were taking a long time because they were waiting for those other entries to timeout before my dns settings were used.

Anyone know what the /etc/resolv.conf symlink is supposed to point to? Right now I just manually edited the file, but I'd prefer to use Ubuntu's default network setup if I can.

  • The symlink should point to: ../run/resolvconf/resolv.conf
    – takeshin
    Jan 11, 2013 at 14:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .