I'm using Ubuntu 12.04, and every time I try to write an Ubuntu ISO image to a disk so I can install it, Unetbootin says /dev/sdb1 isn't mounted. But Ubuntu mounts the drive automatically when it's inserted, right? What can I do to make Unetbootin recognize the drive is mounted?

  • here is a nice trick! to foll unetbootin [how-do-i-use-unetbootin-to-make-a-bootable-windows-usb-installer][1] [1]: askubuntu.com/questions/162174/…
    – user141867
    Commented Mar 20, 2013 at 3:47
  • None of the answers filed to this question solve the issue. Have you managed to get over this? Commented Jan 4, 2016 at 20:03
  • I can't add an answer, but deleting all files from my USB (even hidden ones, found with ctrl+h) helped unetbootin find it, I didn't even have to reboot it. Commented Jun 11, 2016 at 3:35
  • Creating a temp directory /mnt/temp and mounting manually sudo mount /dev/sdc /mnt/temp did the trick for me, where sdc is your drive name.
    – markroxor
    Commented Jul 27, 2018 at 10:29

5 Answers 5


It's possible, as beeju has suggested, that you just need to manually mount the drive. However, you are correct--usually, Ubuntu will automatically mount a drive when it is attached or powered on.

There are two common situations where the problem you've described occurs:

  1. Technically, drives are not mounted. Volumes (i.e., partitions) are mounted. If there is no partition on the drive, Ubuntu cannot mount it (neither automatically nor otherwise). If there is, but it's damaged or (this is much less likely) of a type Ubuntu doesn't recognize, it will also not be mounted.

  2. Unetbootin requires that the partition to which you write the contents of an .iso image be formatted FAT16 or FAT32. (And you should use FAT32 unless your image is tiny and you know you need to use FAT16.) Furthermore, it should be the first partition on the disk, and unless you really know what you're doing and know you need to do something differently, it should be the only partition on the disk and it should take up all the available space. Furthermore (though you don't usually have to do anything to make this the case), it should be a primary (not a logical) partition and the disk's partition table should be of type MSDOS.

If you have valuable data on your disk, then you shouldn't be writing an .iso image to it anyway, because that would destroy the data. Otherwise, you can safely address either or both of the above problems by creating a new partition table on the disk, and then creating a single partition, taking up all the available space, of type FAT32.

One easy way to do this is with the GParted Partition Editor, which is provided by the gparted package. You can install that package in the Software Center. Then run GParted. Select the drive in the drop-down menu at the upper-right corner of the GParted window. Make sure you've selected the correct drive--it would be bad to perform these data-destroying operations on the wrong disk!

Do Edit > Create Partition Table and accept the defaults. Then create a FAT32 partition, also with everything the default. This will make it a primary partition and as big as possible.

Then apply your changes by clicking the green check-mark. You can now mount the drive (or take it out and put it back in, and it should mount automatically). When GParted finishes, close out of it. Then you can write an .iso image to it with Unetbootin.

Alternatively, you might consider using a different method to write the .iso image to the drive, which would let you skip over formatting and mounting the drive.

You can use Startup Disk Creator for this purpose, as described in the official installation instructions.

You can also use dd from the command-line. See dd(1). If you have an .iso image called ubuntu-12.04-desktop-i386.iso and located in your Downloads folder, and if you would write its contents to /dev/sdb1 in Unetbootin, then the corresponding dd command is:

cd ~/Downloads
sudo dd if=ubuntu-12.04-desktop-i386.iso of=/dev/sdb

It's very important that you tell it to output to /dev/sdb (or whatever drive you want it on), not /dev/sdb1 (i.e., not the first partition on the drive).

  • 7
    I was struggling for a while too, it was the filesystem format of the stick that kept it hidden. Formatting it to FAT32 solves the problem.
    – topless
    Commented Oct 20, 2012 at 14:31
  • 2
    This is a perfectly good answer. Why isn't it marked as accepted?
    – Eran Harel
    Commented Jan 22, 2014 at 19:21
  • I am having this same issue on Ubuntu 14.04 and formatting the USB drive to FAT32 has no effect at all. Commented Jan 4, 2016 at 19:59

I didn't get UNetbootin to list my USB drive, but you can force it to use a specific one if you know the device name:

unetbootin installtype=USB targetdrive=/dev/sdb1

You'll find out about your device number by listing all:

sudo fdisk -l

Hope this helps?

  • On Ubuntu 14.04 starting up Unetbootin this way has no effect. Commented Jan 4, 2016 at 20:01
  • Works OK on 16... might also have something to do with UNetbootin version.
    – Hi Lo
    Commented Sep 1, 2016 at 20:10
  • This allowed me to select my thumbdrive properly, I had to mount manually but that is ok.
    – user311189
    Commented Nov 8, 2016 at 8:36
  • 1
    Worked well in 16.04.01.
    – Sebastian
    Commented Nov 12, 2017 at 20:18
  • worked perfectly!!!!!! no time to read the wall of text in that first answer.
    – Pavel
    Commented Feb 4, 2018 at 16:56

I welcome you here!I think it is a common behavior by Ubuntu because the same I experienced on many occasions.What I do at these time that just click on the drive and open it in Nautilus window.Then come back to the particular application which need this drive.It is clearly described here.Moreover,it is better to see this drive is displayed in File system>Media.

  • This has no effect on Ubuntu 14.04. Commented Jan 4, 2016 at 20:02

I found that for me it happens when usb drive is labeled with non ASCII symbols. So try to change it to contain plain ASCII. Not sure about spaces, but it's always better to name it without spaces like drive_8gb.

It's possible to change label using gparted for example when drive is unmounted. Once I labeled it as described and reconnected it, unetbootin started to work well with the drive.


On Linux Mint 19 (based on Ubuntu 18) other advises already here did not help by themselves - renaming partition to ASCII characters only, formatting to FAT32, adding target in command line.

Helped changing drive in Unetbooting graphic interface from partition to drive, that is getting rid of '1' at the end in my case.

BTW, I did not see how I can add several ISO files to drive, and that is why I was trying to use it as advised here: Multi-partition multi OS bootable USB...

EDIT: the issue went away after re-creating partition table for USB stick in question, now Unetbooting works with partitions too (could not boot from resultant stick though...).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .