My wifi is working, but it keeps dropping the connection ever couple of hours. I want to hard-wire it so I don't have to deal with this anymore, but when I plug it in to the modem I'm not getting a connection. The light on the back of the modem is flashing orange. I've had this problem with other motherboards before, and I fixed it by going to the manufacturers website and downloading the drivers. When I went to the manufacturers website, there are only drivers for windows 10.

Here's the link for reference: https://www.gigabyte.com/Motherboard/Z590-AORUS-ELITE-AX-rev-10/support#support-dl

  • What version Ubuntu? Do you have BIOS version F5d installed? Edit your question and show me sudo lshw -C network and cat /etc/network/interfaces and cat /etc/netplan/*.yaml. Also show me sudo iwlist scan and tell me what network you connect to. Start comments to me with @heynnema or I'll miss them.
    – heynnema
    Jun 11, 2021 at 21:46

1 Answer 1


You will not need to do this in the future versions of Ubuntu when support for this Driver propagates. Hopefully not long now...

Common problem for Ubuntu 20.04 since year 2020

Just got it working personally now, but google directed me to your post.

Assuming your version of the Gigabyte Z950 Aorus Elite AX has the same 2.5GB Ethernet Chip. Then the below should work.

  1. Download Linux Driver direct from Realtek website. Below link works now, but google if it doesn't. https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software I selected 2.5G Ethernet LINUX driver r8125 for kernel up to 5.6 released 2021/05/28 version 9.005.06
  2. Download and extract downloaded tar archive
  3. Open terminal and install build essentials..
  4. sudo apt update && sudo apt install build-essential --yes
  5. In extracted directory type
  6. sudo ./autorun.sh

If the above steps work fine, and Ethernet cable connected, nothing obvious forgotten, then your Ethernet connection should be up immediately without restart needed

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .