So I'm trying to get a 'Broadcom Corporation BCM4306' wireless card working with an old ASUS laptop. I've tried looking at other people's solutions however so far nothing has worked. I've tried installing 'firmware-b43-installer' and 'b43-fwcutter' but as stated nothing's happened. The only driver available in the 'Additional drivers' application is the 'software modem' driver. The wireless doesn't work regardless if this is installed or not.

I've tried the top answer from these two threads


1 Answer 1


I had the same problem. My notebook is a HP Pavilion dv 2000. The procedure described in this forum topic [ubuntu] Inspiron 1525 11.04... solved my problem. It is the reply that begins with "PRAISE THE LORD! IT WORKED" XD

I see that you tried to install b43-cutter and firmware-b43-installer. Did also remove bcmwl-kernel-source. Maybe it is that what is preventing the card to work.

The command for that is

sudo apt-get remove bcmwl-kernel-source

Or you can replace "remove" by "purge" if you're as mad as I was with the wireless card. =D

Additional info is provided in the link above. I hope it helps.

ps: It's funny that the same problem ocurred with me on Ubuntu 11.04 but didn't happen on 11.10. Then it happened on 12.04 again.

  • Still says device not ready. Firmware not found.
    – RADXack
    May 10, 2012 at 19:37
  • 1
    On this link is said that the model of your wireless card (4306) must use the legacy driver. Try this command ~$ sudo apt-get install firmware-b43legacy-installer and see if it works. Additional info is provided in the link above. May 12, 2012 at 0:16

Not the answer you're looking for? Browse other questions tagged .