fellow Linuxeers! So, I've had this problem recently when I tried to remove Oracle's Java 7 after it didn't want to work correctly. So, when I tried to:

sudo apt-get purge oracle-java7-install

I get this error at the end of the code:

dpkg: error processing oracle-java7-installer (--configure):
subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already

Errors were   encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

With no other errors in the output. Now why can't I remove the files? It really is an annoying problem, because every time I install/remove something in the terminal the error shows up. Help? Thanks on forehand!


First I purge the java installer PPA using following commands:

sudo rm oracle-java7-installer*
sudo apt-get purge oracle-java7-installer

Than I signed in to technet.oracle.com using my account ID (registration is free to oracle.com)

I then added the PPA, and this time, it was a success.

sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java7-installer

I was able to successfully download from oracle.com. I guess sign-in worked.

  • I tried this, and think it would work but keep running into errors at the very last step. I running debian on a PowerBook G4.By the way I logged in as you suggested. But how does that affect anything? – JGallardo Jan 5 '14 at 20:46

I have resolved that issue by visiting the below link:


  • Thanks! But it didn't work, unfortunately EDIT: Whoa. the apt-get purge worked! thanks alot man! (girl?) – SgtCedric May 11 '12 at 14:38
  • NICE - finally someone did well – user25165 Sep 5 '13 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.