ilshat@lpt:~$ sudo apt-get install synaptic
Reading package lists… Done
Building dependency tree
Reading state information… Done
Package synaptic is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package ‘synaptic’ has no installation candidate
  • I have tried doing a sudo apt-get update but that doesn't work.
  • Have you tried installing it from the Software center ? and try updating the repo by running sudo apt-get update – Srinivas Gowda May 9 '12 at 16:47
  • yes i have tried that also but it wont working.....i am new to ubuntu plz mind that also.. – rohit May 9 '12 at 17:00
  • what your version of Ubuntu? ... please show uname -s output – swift Jul 11 '12 at 16:16
  • @rohit most likely, you have synaptic installed already :) try to type in lens 'syn' – swift Jul 11 '12 at 16:25
  • @swift, not sure how uname -s is going to help here, should probably run lsb_release -r instead to find the version of Ubuntu – tgm4883 Jul 11 '12 at 16:25

Synaptic is available in the so-called universe repository. If you cannot find that package, it means that you do not have universe enabled. To enable it, follow these steps:


Open Software Sources and select Community-maintained free and open-source software (universe)

Software Sources

After doing so, you will be asked to reload the software sources and you will be ready to install your package.


Open the file /etc/apt/sources.list:

sensible-editor /etc/apt/sources.list

And add the following three lines:

deb http://archive.ubuntu.com/ubuntu/ quantal universe
deb http://archive.ubuntu.com/ubuntu/ quantal-updates universe
deb http://security.ubuntu.com/ubuntu/ quantal-security universe

Note: I'm assuming that you are using Quantal (12.10). If this is not the case, then use lsb_release -c to find the codename of your Ubuntu release and replace quantal with that codename.

Then run sudo apt-get update and install Synaptic.


Fixing /etc/apt/sources.list was not enough for me:

deb http://br.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://br.archive.ubuntu.com/ubuntu/ precise-updates main restricted

Then I did an apt-get update: got lots of invalid signature errors.

It was company's proxy.

Only then apt-get update worked and I could install packages again.


That error means that the repositories you are using don't have the synaptic package in them, but apt can see other packages refer to the synaptic package. What repository are you using? If you can change back to the defaults (archive.ubuntu.com) then do an apt-get update you should be able to install it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.