Something weird is happening with the epiphany browser (gnome web). A few days ago, it stopped working. I can still see the icon, though:

enter image description here

Unfortunately, clicking the icon does not trigger the opening of the browser.

The odd behavior does not end here. If I try to remove it on the shell, it does not work:

~$ sudo apt-get remove epiphany-browser 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'epiphany-browser' is not installed, so not removed

I even tried to re-install it with:

~$ sudo apt-get update -y
~$ sudo apt-get install -y epiphany-browser

Now, there is a second epiphanny going on!

enter image description here

Fortunately, the second epiphany (the new one) works!

Finally, there is another weird thing. I tried to remove epiphany hoping that both of them would be removed.

Nonetheless, after doing the following only the newest one was removed! The old one which does not work was kept.

$ sudo apt-get remove epiphany-browser 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 3.922 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 244712 files and directories currently installed.)
Removing epiphany-browser (3.36.4-0ubuntu1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...

Does anyone know why this is happening? Is there a way to fix it?

==== UPDATE ====

(@Terrance suggested putting the output of snap list. I think he found the problem).

The output of snaplist is:

~$ snap list
Name               Version                     Rev    Tracking         Publisher   Notes
code               054a9295                    65     latest/stable    vscode✓     classic
core               16-2.50.1                   11167  latest/stable    canonical✓  core
core18             20210507                    2066   latest/stable    canonical✓  base
epiphany           3.36.4-4-gc6d3adbdac        76     latest/stable    jbicha      -
gnome-3-28-1804    3.28.0-19-g98f9e67.98f9e67  145    latest/stable    canonical✓  -
gnome-3-34-1804    0+git.3556cb3               72     latest/stable/…  canonical✓  -
gtk-common-themes  0.1-52-gb92ac40             1515   latest/stable/…  canonical✓  -
snap-store         3.38.0-63-g766b86f          542    latest/stable/…  canonical✓  -
snapd              2.50.1                      12057  latest/stable    canonical✓  snapd
  • 1
    What is the output of snap list?
    – Terrance
    Jun 10, 2021 at 13:37

1 Answer 1


This fixes it:

$ sudo snap remove epiphany 

Thanks @Terrance. The problem was clear after his question on a comment.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.