1

As the title says, hotspot on 20.04.2 and network settings in general seem to be extremely bugged. Not sure what's going on but it's annoying and I unfortunately am not good enough with ubuntu to do this without a GUI.

My aim is to take the ethernet signal that my server is putting out and turn it into a hotspot for my devices, as my 3d printer, printer and TV are in another room.

I'm going to start from the beginning and try everything again here.

I open the network settings.

Wi-Fi Settings

First of all, this screen is significantly simpler than I remember in the past, especially with regards to hotspots, which I think is part of the same issue.

I click 'turn on wifi hotspot'.

turn on wifi hotspot

The prompt says "Must have a minimum of 8 characters" yet an exactly 8 digit password is rejected, as is a 9 digit password.

8 digit password rejected

9 digit password rejected

I use password 'Test1', and that works, because the default encryption type is WEP. (Why???)

I cannot see this hotspot on my Note 9 running Android11. My Windows 10 laptop with verified working wifi card can see it, but immediately says 'Cannot connect to this network' when selecting 'connect'. An ubuntu laptop sees it, but will not connect.

I open sudo nm-connection-editor, and hit edit on the hotspot.

The connection mode is not on hotspot, it is on ad-hoc by default.

ad-hoc by default

Again, why?

I change that to hotspot and sudo service network-manager restart.

The wifi is not 'not connected', with no options for a hotspot.

The wifi is not 'not connected'

I go to the network settings, and the 'turn on wifi hotspot' option is grayed out.

'turn on wifi hotspot' option is grayed out

Clicking another submenu and coming back to wifi settings doesn't fix that.

I restart the VM, but the 'turn on wifi hotspot' option is still grayed out, so I delete the connection with nm-connection-editor.

I now create the hotspot again with the default UI, making the password the same.

This time I leave the Mode alone, but change the Wifi security type to Wpa/wpa2 personal and the password to Test1234, and sudo service network-manager restart. Again, I am now not connected and I cannot turn on the hotspot.

Right, since that's not working, I create a new wifi connection from nm-connection-editor.

create a new

wifi connection

Connect automatically? Yes

SSID: test

Mode: Hotspot

Band: 2.4ghz

IPV4 method: Shared to other computers

Security: WPA/WPA2 Personal

Password: Test1234

`Turn on wifi hotspot' is now grayed out again, and the hotspot is not visible in the 'wifi' or 'network' parts of the settings to enable it.

now grayed out again

Without doing anything else I restart again. Since 'connect automatically' is checked I assume I will see the hotspot on when I reboot.

No such luck, and 'turn on wifi hotspot' is still grayed out.

I try clicking 'connect to hidden wifi network' and connecting to my hotspot I made in nm-connection-manager.

'connect to hidden wifi network'

It's unsuccessful, but now the option to 'turn on wifi hotspot' is ungrayed.

When I click that, it resets the previous settings to the following:

Connect automatically? Yes

SSID: test

Mode: ad-hoc

Band: 2.4ghz

IPV4 method: Shared to other computers

Security: WEP

Password: 11b1e27a57

It's now connected, but of course still doesn't work properly.

When using nmcli connection up test I get:

Error: Connection activation failed: No suitable device found for this connection (device enp1s0 not available because profile is not compatible with device (mismatching interface name)).

I think I might be able to fix that by defining the interface in /etc/network/interfaces with iface enp1s0 inet dhcp or something similar but I'm not sure if those are the correct flags for a hotspot.

Edit: my wifi device is called 'wlp4s0' in nm-connection-editor so I have no idea why nmcli is trying to use enp1s0 as that's my ethernet connection. I have the interface correctly assigned in nm-connection-editor.

Does anyone know how to do this via terminal/gedit/nano/ whatever? Does anyone know why it's acting like this??

https://pastebin.ubuntu.com/p/6tpbggXtwK/

Pastebin of inxi -Fxz

5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.