In 8.04, 9.04, 10.04 and 11.04 I have been able to connect to a Windows 2003 server. It has been simple and effective.

Since loading 12.04, I can't do it. The error highlights the password (which works on the 11.04 laptop beside it). In fact, no password is acceptable.

I have tried it with Ubuntu and Xubuntu 12.04 with the same result.

Likewise, the answers posted with "Cannot connect to Samba share from Nautilus" have not resolved the issue.

  • While I am not saying this question should be interpreted as an attempt to report a bug and closed as off-topic, if a bug hasn't been reported for this, it should be, since it worked with previous versions of Ubuntu but stopped working in 12.04. travis's answer may provide some insight into reporting the bug (assuming that works for you). – Eliah Kagan Jul 12 '12 at 12:02

I was having this same issue. I got it to work by entering the domain with all capital letters. Never have I had to do that before.

  • I've been trying for the last couple hours to get my shares to work until I ran into this. When did Windows become case sensitive. Ugh! – aNoble Jun 20 '12 at 0:22

I got this answer in a different thread, and it works perfectly.

In /etc/samba/smb.conf add the following to the bottom of the [global] section:

client lanman auth = yes 
client ntlmv2 auth = no
  • You've posted what is essentially this answer, in three places. Can you edit your answers to include a link to the source of this information? – Eliah Kagan Jul 12 '12 at 11:58
  • The all-caps solution did not work for me, but this did. Thanks. – Randall Cook Sep 16 '12 at 17:15
  • Yes, I'm WAY late upgrading. I spent hours trying to find a solution and this is the one that finally worked. Thanks!! – bcworkz Oct 19 '13 at 2:55

Works for me. I hit Alt+F2, then I enter the UNC share location in the form: smb://server-name/sharename or smb://servername/c$ and hit Enter.

I'm then presented with a login box, where I enter the windows username, the domain name and the windows password. Tip: I change /etc/samba/smb.conf's "WORKGROUP" to the domain name so it automatically populates in the login box.

Perhaps you could check to ensure samba-common is installed?

sudo apt-get update
sudo apt-get install samba-common

Also, maybe your domain uses some funky authentication settings in `/etc/samba/smb.conf.

protected by Community Oct 7 '12 at 10:33

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.