0

In my Ubuntu 18.04 sound setting I have only Radeon RX 580 as available option. So the PC outputs no sound, though I can get sound from TV output, but I'd like to get sound directly from the PC to my headphone jack.

Here are some more info:

pc@media:~$ sudo lshw -c sound 
  *-multimedia              
       description: Audio device
       product: Ellesmere [Radeon RX 580]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0.1
       bus info: pci@0000:26:00.1
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:49 memory:fcf60000-fcf63fff
  *-multimedia
       description: Audio device
       product: Family 17h (Models 00h-0fh) HD Audio Controller
       vendor: Advanced Micro Devices, Inc. [AMD]
       physical id: 0.3
       bus info: pci@0000:28:00.3
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm pciexpress msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:51 memory:fce00000-fce07fff

I have many tricks that I found like reinstalling pulseaudio but none worked. So appreciate your help.

0

At last: the official Ubuntu troubleshooting guide came to resque:

https://help.ubuntu.com/community/SoundTroubleshootingProcedure

Followed all steps meticulously but only after editing /etc/modprobe.d/alsa-base.conf and adding

options snd-hda-intel model=auto 

And reboot, Line out appeared in the sound setting options window and the sound is there.

0

In my case, after updating the system, a similar error occurred with the lack of drivers for the sound.

The solution was to install the package:

sudo apt install linux-modules-extra-5.8.0-55-generic

and reboot

To verify which version you need to install, type: cat /proc/version

Linux version 5.8.0-55-generic (buildd@lgw01-amd64-050) (gcc (Ubuntu 9.3.0-17ubuntu1~20.04) 9.3.0, GNU ld (GNU Binutils for Ubuntu) 2.34) #62~20.04.1-Ubuntu SMP Wed Jun 2 08:55:04 UTC 2021

You can also try:

sudo add-apt-repository ppa:ubuntu-audio-dev
sudo apt-get update
sudo apt-get dist-upgrade

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.