3

System Info

  • Dell Inspiron 5515
  • Operating System: Kubuntu 21.04
  • Kernel Version: 5.12.9-051209-generic
  • OS Type: 64-bit
  • Processors: 16 × AMD Ryzen 7 5700U with Radeon Graphics
  • Memory: 15,1 GiB of RAM
  • Graphics Processor: AMD RENOIR

If I suspend my pc, the screen, fans and keyboard backlight turn off. However if I try to wake up from suspension the screen stays black, while the keyboard backlight starts blinking. The only way to unlock it is to click the power button, and the pc will automatically restart (thus losing the data of the active session).

Initially I had the 5.11 kernel, then to see if the problem was solved I tried to install the 5.12 kernel and the 5.12.9 kernel, but there were no improvements.

2
  • I started experiencing this same issue when I had upgraded to kernel 5.11.0-17. Then, kernel 5.11.0-18 was released very quickly. I upgraded to it, and the issue went away. I have an Intel i7 processor and Nvidia graphics, so our hardware is very different. But I think you are on the right track suspecting the kernel version is the culprit. A work-around that helped me while I had this issue was disabling blank screen for power saving: System Settings | Power | Power Saving | Blank Screen | Never. May be you can give this a try until the issue is fixed in the kernel.
    – Enterprise
    Jun 6, 2021 at 4:10
  • I had the same issue under Ubuntu 21.04 with kernel 5.11.0-25. Booting 5.11.0-22 solved it for me. Aug 15, 2021 at 18:23

6 Answers 6

2

I also had this problem with 20.10 and now with 21.04.

I have this issue with both Kubuntu running on Lenovo T14 (AMD Ryzen 7 PRO 4750U with Radeon Graphics, Renoir)

and Arch Linux Lenovo T470p w/ Nvidia - KDE, lightdm

$ journalctl -xe -b-1
kernel: Freezing user space processes ... 
kernel: Freezing of tasks failed after 20.008 seconds (1 tasks refusing to freeze, wq_busy=0):
kernel: task:kscreenlocker_g state:D stack:    0 pid: 8675 ppid:  3403 flags:0x00000004

Googling has not really revealed what the real issue is... Most suggest graphics card drivers.

Until then, what prevents freeze for me is to have Screen Locking After waking from sleep disabled.

2
  • thanks for the reply, but unfortunately in my case it didn't solve the problem.
    – Federico
    Jun 6, 2021 at 8:07
  • Disabling screen lock after sleep solved the black screen on wake issue, but output video buffer becomes an unrecoverable mass of random colors ~50% of the time - I can make out the outlines of windows, so the OS seems to be running, but the video out is borked. System specs: Ubuntu 20.04, kernel 5.4.0-92-generic, AMD Ryzen 7 5800X, GeForce GTX 970. Jan 8 at 23:59
1

I had the same issue on the same PC but on KDE neon.

Now, with the 5.14.0 kernel, it just works fine.

3
  • 1
    yes, you're right :)
    – Federico
    Sep 7, 2021 at 12:04
  • How did you install 5.14 kernel on KDE Neon. I tried it before but got missing dependency.
    – amru
    Sep 9, 2021 at 18:27
  • @amru I just installed it through Mainline and it worked on reboot.
    – Mario
    Sep 18, 2021 at 9:14
1

With the latest 5.13-rs6 kernel update the problem seems to be partially solved. That is, when I try to wake up the pc the keyboard starts flashing, but then if I press the power button again, the pc does not restart, but wakes up from suspension (as it should).

It is not advisable to install rc kernel for your main machine (it would be better to wait for the final version, that is the one without rc in the name).

In any case to install the 5.13-rc6 kernel (be careful check that the files are the right ones for your machine), follow the instruction in this article: How to Install the Latest Mainline Linux Kernel Version in Ubuntu

1

This is a known error, and still persists in Kernel 5.15, as outlined by many in this thread on Reddit: Lenovo Thinkpad L14 Gen2 AMD Linux incompatibilities as well as on the Lenovo forums. As you can see here the reported hardware is different, but it always refers to the AMD Ryzen 5xxx CPUs which seem to have severe issues with deep sleep on Linux. The reported issues have a workaround, which is to find out which sleep state does work on your machine, and then to make sure only the one working is called. This sadly has to do it for now, until someone reported this to the Linux Kernel bugzilla, or if someone decides to fix this in a more recent Linux Kernel and backport it to older versions. You can find some more information about the issue in this Manjaro forum post.

1
1

Confirmed working with BIOS version 1.20.1.17, see this post on Reddit.

1

I am on PopOS 20.04 which an ubuntu based distro. A week ago kernel update 5.15 released and now the problem is gone.

It also fix for sleep when you have dual os. My advice is to upgrade your kernel to at least 5.15.5 or newer, or wait the update

3
  • Ugh. Wish I had your experience. I'm using PopOS 20.04 with kernel 5.15 -- but on Ryzen 5500U -- and the sleep issue is not fixed. It just "sleeps" with a black screen that can't be restored without a reboot.
    – The Roark
    Dec 26, 2021 at 19:03
  • Looks like it only fix for 4000 series. My device is running on 4500u. Have you tried to update using latest kernel 5.15.8? Dec 27, 2021 at 9:32
  • Yes! Unfortunately, no luck. It's a new computer, so now trying Fedora - then Manjaro.
    – The Roark
    Dec 27, 2021 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.