I saw this similar question with no definitive answer.

What I think that I need

What I want to do is to prevent any update of my Nvidia graphical card. I tried to put it on hold, but I couldn't find the name of Nvidia driver package.

My problem:

When I run sudo apt upgrade and there is a driver of nvidia on the list, usually some problem occurs later:

  1. My PC doesn't recognize second screen;
  2. When I try to turn on my PC it gets stuck on Ubuntu logo screen. When it happens, I need to force to shutdown via power button, turn on again via power button, and then appears to me the GNU GRUB black/white screen:

enter image description here

I then select advanced options for Ubuntu and try the different kernel versions. Like the screen below (this is an old photo):

enter image description here

  1. Last week this alternative didnot work, and I had to do a fresh install on Ubuntu.

My temporary solutions so far:

  • Once I am able to log in on my PC, I try to use a different version of nvidia card via Software & Updates -> Additional Drivers. Right now, I am using nvidia-driver-390. This is my current list:

enter image description here

  • Avoid using sudo apt upgrade for a while. But it never works well, because I usually need to install a new software, and the nvidia update comes together.


UBUNTU 20.04.2 LTS, DELL G3 3590

Graphics Card: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] / Intel Corporation UHD Graphics 630 (Mobile)

Thanks in advance

  • According to Nvidia you should be using 460 for that graphics card at the moment of this writing. It should work fine and be kept in the same branch until it gets out of support. At that point you should be running with the latest long term support driver for legacy hardware and enjoy a few more years of support. Preventing updates, forcing an old driver version is not a solution, to anything. You should troubleshoot the actual problem, not what you think is a solution (it clearly isn't). (...) Jun 5, 2021 at 14:41
  • (...) Start by updating UEFI, making sure the OS is installed in UEFI mode with Secure Boot disable and also that Fast Boot in UEFI is disabled. And, if dual-booting also disable Fast Startup in Windows. Jun 5, 2021 at 14:41

1 Answer 1


First, to find out what NVIDIA driver package you have installed, run dpkg -l | grep nvidia-driver. You'll see output like this:

$ dpkg -l | grep nvidia-driver
ii  nvidia-driver-465                             465.19.01-0ubuntu1                                      amd64        NVIDIA driver metapackage

In my case, I have nvidia-driver-465 installed, and based on your screenshots, I'm guessing you'll have nvidia-driver-390. You can prevent apt from automatically upgrading a package by using hold on it:

sudo apt-mark hold nvidia-driver-390

However, as mentioned, it's worth noting that the 390 series is very old, and nvidia-driver-460 should work for your card. If updates to the driver package are causing problems that are not solved by a reboot, you may have something else wrong with your system.

  • Thank you. I will try the @ChanganAuto suggestions later (some of them I already use). So far, I will be stuck with this version. At least, my PC works as desired. Jun 6, 2021 at 23:33
  • I have GTX750Ti and it works fine with 390 however, every now and then ubuntu updates it and I get similar problems. a) resolution drops to < 50% b) black dots on Blender screen - display only the saved render files are fine. Speed seems to be ok etc etc. Very annoying. Will hold 390 and see what happens in a year or two. Maybe GPUs will be cheaper and I will upgrade!
    – paddyg
    Oct 20, 2021 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .