2

I keep on getting previews only for active windows but I've been told that newer versions of Compiz support preview of minimized windows too. Who's right?

And does the option "Keep previews of minimized windows" in Workaraounds help? I turned it on but to no avail.

  • Did you try installing the package compiz-plugins and then going to CCSM, and enabling Thumbnail Window Previews there? – Zatrapilla Apr 7 '14 at 12:39
1

In CompizConfig Settings Manager Install compizconfig-settings-manager you can activate the plugin Enable Window Previews, which doesn't show previews for minimized windows. (When I first checked this, I saw previews - but now I can't reproduce it. Seems to be buggy.)

Previews for windows on other workspaces are optional; activate them by unchecking Taskbar Shows Only Windows of Current Viewport.

Compiz Wiki says: "The Window Previews displays a small thumbnail of any displayed (not minimized) window when you hover over it's button in your desktop environment's window list."

But always keep in mind: CCSM is an advanced tool. Use with caution. This tool allows you to deeply configure Compiz's settings. Some options may be incompatible with each other. Unless used with care, it is possible to be left with an unusable desktop.

  • Hi Jakob link – AleCes May 12 '12 at 10:36
  • 1
    Here it says newer versions of Compiz should indeed support previews of minimized windows . I also discovered a bug report about this. It'd be interesting to know whether this bug concerns only a limited number of users or if it's generalized instead. – AleCes May 12 '12 at 11:08
  • You,re welcome. May I ask you what version of Compiz you're using? If it's newer than or equal to 0.9.2, then you should have previews of minimized windows, if you don't, then you too are affected by the bug. – AleCes May 12 '12 at 11:42
  • I use Compiz 1:0.9.7.8-0ubuntu1 - the "normal" 12.04 version (at the moment). Keep in mind that this blog entry is already 1 1/2 years old. Possibly this bug never became solved? In this blog entry it was called "experimental". – Jakob May 12 '12 at 12:06
  • Yeah, it's the same as mine. As I said, it would be interesting to find out whether everybody has this bug or it's some quirk that affects some and not others. Have you tried CompizConfig>Workarounds>Keep previews of minimized windows? Please let me know if this works for you. In any case, it didn't for me. – AleCes May 12 '12 at 12:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.