2

My computer is stuck on black screen with cursor before Login after booting into Ubuntu 20.04, nothing is working, even cursor is not moving, its freeze, i also tried CTRL+ALT+F4 its not opening the terminal. When i restart the system and in grub menu select the Advance options for Ubuntu and select the recovery mode, the recovery mode is not working too, its stuck. Only old recovery mode is working. How to Fix this problem?

Update

During OS installation i think i have selected the option to install 3rd party drivers, firmware, codecs, etc.(not sure)

Hardware Specs:

Intel Core i7 ,Gtx 1060 ,16 Ram ,1TB nvme ssd

enter image description here

enter image description here

12
  • Press "e" to edit the entry you're trying to boot and remove "splash" or even "quiet splash". Does it boot now or if i doesn't what are the error messages? Jun 5 at 13:23
  • @ChanganAuto i didn't get your point. i am stuck on black screen with a cursor, nothing is working
    – Askani
    Jun 5 at 13:38
  • Yes, but that is after the Grub menu selection, isn't it? If not I don't see the point of posting a photo of the Grub menu. Is at that Grub menu that you can try what I suggested. Jun 5 at 13:40
  • @ChanganAuto yes after selection... i post grub bocz i wanted to mention that old version is working, but default is not working.. it was working yesterday and before.
    – Askani
    Jun 5 at 13:43
  • So, before pressing enter on the default, edit it as explained above. This is for testing purposes only. mIf it works then you can make it permanent. Jun 5 at 13:45
0
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-375 nvidia-settings
2
  • Its stuck on black screen after boot, i am not able to login and open anything.
    – Askani
    Jun 17 at 18:17
  • edit grub option as suggested in other comments and upgrade graphics drivers
    – jasmines
    Jun 18 at 6:30
0

On grub menu i select Advance options for Ubuntu then i select Ubuntu, linux 5.8.0-53-generic instead of Ubuntu, linux 5.8.0-55-generic(it was the default one which was not working), after booting and login into the system i went into software updater, software updater was giving me the option of Partial Upgrade or Continue, i selected the Partial Upgrade, it removed and installed some packages now the default Ubuntu, linux 5.8.0-55-generic is working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.