2

I have multiple issues with Redshift.

The first issue has to do with two Redshift instances running simultaneously. There are five processes in GNOME System Monitor as seen in this image, but I think that there are two instances because I see two icons in the system tray as shown here, and both act like two instances. E.g., if I place my redshift.conf file in ~/.config then reboot, the two will fight each other, continuously changing from red to no red during the day.

However, if I install Redshift afresh, there's only one instance. The problem arises when I reboot.

The next issue has to do with my redshift.conf file. I've set it up correctly, with the right lat and lon, both negative because I live in the Americas. But, the redness effect is applied during the day regardless. This happens with one Redshift instance. I've described above what happens with two.

And lastly, Redshift comes back after I close it, even with autostart disabled. E.g., if I click on "Quit," the redness effect goes away if any, the icon in the system tray disappears, then a new one comes up and so does the redness effect if applicable. This happens when there are two instances and when there's only one instance.

A few things worth noting are that I'm on Lubuntu 21.04 and I installed the status icon program to control Redshift and Redshift itself via Discover.

Also, here's the content of the redshift.conf file:

[redshift]
; Set the day and night screen temperatures
temp-day=5800
temp-night=4800

; Enable/Disable a smooth transition between day and night
; 0 will cause a direct change from day to night screen temperature.
; 1 will gradually increase or decrease the screen temperature
transition=1

; Set the screen brightness. Default is 1.0
;brightness=0.9
; It is also possible to use different settings for day and night since version 1.8.
;brightness-day=0.7
;brightness-night=0.4
; Set the screen gamma (for all colors, or each color channel individually)
gamma=0.9

;gamma=0.8:0.7:0.8
; Set the location-provider: 'geoclue', 'gnome-clock', 'manual'
; type 'redshift -l list' to see possible values
; The location provider settings are in a different section.
location-provider=manual

; Set the adjustment-method: 'randr', 'vidmode'
; type 'redshift -m list' to see all possible values
; 'randr' is the preferred method, 'vidmode' is an older API
; but works in some cases when 'randr' does not.
; The adjustment method settings are in a different section.
adjustment-method=randr

; Configuration of the location-provider:
; type 'redshift -l PROVIDER:help' to see the settings
; e.g. 'redshift -l manual:help'
[manual]
lat=-35
lon=-55

; Configuration of the adjustment-method
; type 'redshift -m METHOD:help' to see the settings
; ex: 'redshift -m randr:help'
; In this example, randr is configured to adjust screen 1.
; Note that the numbering starts from 0, so this is actually the second screen.
[randr]
screen=0

Any ideas?

10
  • 1
    You haven't added redshift (or redshift-gtk | redshift-qt) to an autostart have you? as it has a 'autostart' feature, where if both are utilized, there will be two running (one you started; the one as consequence of telling redshift to autostart itself). As for lat/long, I didn't understand the +/- values so just used whatever I found worked for me (trial and error as details search engines provided didn't match they way redshift conf file wanted it)
    – guiverc
    Jun 3 '21 at 22:42
  • Yes, I've added Redshift to an autostart and enabled the autostart feature. I'll test removing the first autostart, then I'll let you know of the outcome. @guiverc
    – user1200336
    Jun 4 '21 at 20:18
  • Here's what I did: 1) uninstall both programs, 2) reboot, 3) install them again, 4) remove Redshift from applications startup, 5) open Redshift, 6) enable the autostart feature, and 7) reboot. All while having my redshift.conf file in ~/.config. However, the outcome is nearly the same. The screen still continuously switches between red and no red during the day. This time, only one icon appears in the system tray. Also, instead of five processes running in the background, there are three. One of them is named "redshift-gtk" while the other two are named "redshift." @guiverc
    – user1200336
    Jun 4 '21 at 22:28
  • I think that the status icon program has something to do with this because Redshift works perfectly if I have that program uninstalled. What are your thoughts? @guiverc
    – user1200336
    Jun 4 '21 at 22:28
  • By status icon do you mean redshift-gtk (or redshift-qt) as I'm not sure what you mean. I like having a redshift icon on my panel so I can disable it when I need to concentrate and the redshift is working against that. If you start redshift-qt for example (or -gtk) it'll start redshift itself... so do not start a GUI tool (redshift-gtk for example) and the backend redshift` as that will result in two running (the GUI frontend will start it's own redshift backend). I'd suggest checking manual.lubuntu.me/stable/3/3.2/3.2.13/session_settings.html and what you have autostarting.
    – guiverc
    Jun 4 '21 at 22:44
1
+50

I had the same problem after upgrading from 20.10 to 21.04.

It seems that there is one instance started by systemd (which crashes and gets restarted several times) and one instance started via the app itself by enabling autostart (which creates an entry ~/.config/autostart/redshift-gtk.desktop)

By removing redshift-gtk.desktop the flickering stopped, but redshift-gtk still crashed. I assume that it was either started to early or was missing a DISPLAY env-variable.

I had a hard time to remove redshift from systemd. Disabling or masking the redshift-gtk.service did not work. Still crashed on startup. I found that you have to disable the service with:

sudo systemctl --global disable redshift-gtk
sudo systemctl --global disable redshift

If you then enable the autostart via ~/.config/autostart/redshift-gtk.desktop it works as expected.

1
  • You're my hero! Thank you so much :D
    – user1200336
    Jun 28 '21 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy