73

How can I restore the Firefox 89 design to the old one?

Specifically the tab design. I can't tell (easily) what tab is open.

I can't find anything in the menus.

I'm running Firefox 89 on Ubuntu 21.04 (Hirsute Hippo).

3
  • 7
    Since this question is applicable to all operating systems, would Superuser be a more appropriate SE site? Jun 5, 2021 at 0:24
  • 1
    The most terrible thing IMO are the "styled" alert boxes: "This page is asking you to confirm that you want to leave" — holy heck, a shock each time! They don't look like they are coming from the browser, at all.
    – Levente
    Jun 6, 2021 at 19:27
  • For Firefox 90+ try: superuser.com/a/1669549/9067 Mar 4 at 6:52

4 Answers 4

60
  1. copy and paste this to the URL bar:

    about:config
    
  2. search this:

    proton
    
  3. set the following values to false:

    • browser.proton.enabled
    • browser.proton.modals.enabled
    • browser.proton.doorhangers.enabled
    • browser.proton.contextmenus.enabled
9
  • 23
    I've seen claims that the browser.proton.*.enabled flags are planned to be removed in v90; so this probably won't be a long term fix. V78 ESR will remain an option until later in the year, but will be retired in favor of v91 ESR at the end of October. bugzilla.mozilla.org/show_bug.cgi?id=1709425 wiki.mozilla.org/Release_Management/Calendar Jun 4, 2021 at 13:56
  • 7
    Look at forks of.Firefox. there are many. Some will keep.older UI or features.
    – Stilez
    Jun 4, 2021 at 14:17
  • 3
    This will do until the next destructive nonsense Mozilla come up with Jun 6, 2021 at 12:57
  • 6
    @Dan let's hope that by when they retract these flags they iterate the design somewhat, taking feedback into account...
    – Levente
    Jun 7, 2021 at 2:36
  • 2
    Looks like this no longer works in Firefox 91. All of these are ignored. Gawd, the horrible UI is back.
    – ADTC
    Aug 12, 2021 at 21:11
13

Alternative solution: use a theme like Qiyu Light that highlight the current tab:

Firefox tab bar in Qiyu Light theme

Original idea: https://www.reddit.com/r/firefox/comments/npz18m/firefox_89_new_tab_design_is_awful/h08fdnp/

2
  • 1
    Yeah, I was going to recommend finding a different theme, given the specific problem with visibility. I always use custom themes in Firefox on Linux.
    – trlkly
    Jun 4, 2021 at 17:36
  • 1
    Good idea. I'll keep this in mind in case Mozilla remove the ability to edit the flags. Jun 5, 2021 at 20:10
6

The option to disable the new UI will inevitably be removed from about:config. A more long-term solution is to use userChrome.css.

It can change the tab colors, but I didn't have to use it for this purpose: I have FF theme set to 'System' and the system theme I'm using paints the inactive tabs (and the rest of the top bar) black even after the update to FF 89.

My primary complaints were:

  • Tab bar height too large
  • Spacing in bookmarks menu too large

Both can be fixed. Check this for detailed instructions, but in short:

  • In about:config, set toolkit.legacyUserProfileCustomizations.stylesheets to true.

  • Open the profile folder: in about:support, find the row called Profile Folder and click Open Folder next to it.

  • In that directory, create a directory called chrome, and in it create file userChrome.css.

  • userchrome.org has some suggestions for what to put in there, aimed at achieving pre-FF-98 look (among other things).

    I ended up with following file, which decreases bookmark menu spacing, and tweaks the tab bar design (which decreases its height and makes it look almost like before the update).

    Note that any changes to the file are applied only after restarting FF.

    /*** Tighten up drop-down/context/popup menu spacing ***/
    
    menupopup > menuitem, menupopup > menu {
      padding-block: 4px !important;
    }
    :root {
      --arrowpanel-menuitem-padding: 4px 8px !important;
    }
    
    /*** Proton Tabs Tweaks ***/
    
    /* Adjust tab corner shape, optionally remove space below tabs */
    
    #tabbrowser-tabs {
        --user-tab-rounding: 0px;
    }
    @media (-moz-proton) {
        .tab-background {
        border-radius: var(--user-tab-rounding) var(--user-tab-rounding) 0px 0px !important;
        margin-block: 1px 0 !important;
        }
    }
    
    /* Inactive tabs: Separator line style */
    
    @media (-moz-proton) {
        .tab-background:not([selected=true]):not([multiselected=true]):not([beforeselected-visible="true"]) {
        border-right: 1px solid rgba(0, 0, 0, .20) !important;
        }
        /* For dark backgrounds */
        [brighttext="true"] .tab-background:not([selected=true]):not([multiselected=true]):not([beforeselected-visible="true"]) {
        border-right: 1px solid var(--lwt-selected-tab-background-color, rgba(255, 255, 255, .20)) !important;
        }
        .tab-background:not([selected=true]):not([multiselected=true]) {
        border-radius: 0 !important;
        }
        /* Remove padding between tabs */
        .tabbrowser-tab {
        padding-left: 0 !important;
        padding-right: 0 !important;
        }
    }
    
1
  • 1
    Thanks so much. I have been desperately looking for a way to get rid of the double spaced bookmarks. I've seen variants of this approach several places, but this is the only one that actually worked. I don't care about the tabs, so just the first section here ending before Proton Tab Tweaks was what I needed. Jun 6, 2021 at 14:43
3

There is also a ready-made userChrome.css fix at: https://github.com/black7375/Firefox-UI-Fix

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.