0

I am trying to install UC20 on an old Dell machine. The machine has no UEFI capability. CPU is Intel 2160@1.80 GHz with 2GB RAM.

I installed UC20 using dd on this machine. However, before grub I get a message "error: invalid signature". Then I see a grub kernel selection menu, and any selection leads to "error: invalid signature..." message and back to the grub menu screen.

The behavior is the same when I tried to run UC20 in a Virtualbox. However, the VM on Virtualbox boots up and works fine as soon as I enable EFI.

Screen shot of the boot screen, which loops back to the same screen over and over

This is what I see when I look at the partition information for the disk I created using dd.

Device Start End Sectors Size Type
/dev/sdb1 2048 4095 2048 1M BIOS boot
/dev/sdb2 4096 2461695 2457600 1.2G EFI System

I searched and so far could not find any solution. I also unsuccessfully tried building different UC20 images using Ubuntu image with different combinations of pc snaps with the hope that some pc-gadget snap would support legacy BIOS boot.

btw, Ubuntu Core 18 runs fine on this machine.

Is it not possible to run UC20 on non-UEFI system?

Would appreciate help in this regard.

2
  • Did you verify the hash of the file you downloaded to make sure it wasn't corrupted?
    – kyrofa
    Jun 3 '21 at 16:58
  • Yes. verified downloaded file. I also created my own image using ubuntu-image. The results are the same. Jun 3 '21 at 18:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.