My Lenovo Ideapad S10-3s, which is using Ubuntu 12.04 LTS, does not hibernate. The error message shown is PM: Not enough free swap, although my swap is around 3GB and my RAM only around 1GB.

How can I make it hibernate? I have already tried doing this How to enable hibernation? to enable my hibernation.


This is the screenshot after I used the swapon -s command suggest in neon_overload's answer:

image of swapon -s result

2nd Update

I solved this problem by installing zramswap-enabler from:




After I installed zramswap-installer and rebooted my netbook, it is able to hibernate.

The screenshot of swapon -s after I installed zramswap-enabler: image of swapon -s result

1 Answer 1


swapon -s will display how much swap you actually have mounted at the moment.

It is possible that you have a 3GB swap partition but for some reason it isn't being mounted. It'll also tell you if there is anything abnormal about your swap usage. If you continue to have problems, tell us the output of this command.

The swap partition is mounted in /etc/fstab (typically).

Another thing to keep in mind is that if you selected to encrypt your home directory during the Ubuntu install, your swap partition will also, by default, be encrypted. Due to the way this is done it's no longer possible to hibernate (it would be difficult to have disk encryption but also allow hibernation and still be secure, and Ubuntu's chosen method of home directory encryption does not support it).

Edit: as seen in the comments, it became apparent that this user had both zRam-based swap (which is like compcache) and disk-based swap, and solved his/her problem by installing zramswap-enabler.

  • This is the screenshot after I used that commad: link May 9, 2012 at 11:19
  • Interesting, you have some compressed RAM-based swap there. I'm afraid I don't know enough about it to know how it would affect hibernation - hibernation should be smart enough to ignore it, and just use the 3GB disk-based swap. But it might be worth trying unmounting the zram-based swap and just using disk-based swap? Maybe someone else can be of more help. May 10, 2012 at 2:15
  • thanks for your idea about unmounting the zram, because when I searching how to unmount zram, I found these links, link1 link2, which lead me intalling zramswap-enabler. After I insalled that package and reboot, my Lenovo netbook become able to hibernate. NB: Sorry if my english doesn't very good. May 10, 2012 at 5:55
  • Glad you were able to solve your problem. Interestingly, your output of swapon -s after using zramswap-enabler appears to indicate that you've removed your zRam-based swap. Not that that's necessarily a bad idea, since it was giving you problems (and is not part of a standard install). May 10, 2012 at 7:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .