5

I'm using Ubuntu 20.04 LTS. I've recently installed Matplotlib for Python 3.9 and when I try to plot a graph it gives me the error:

Matplotlib is currently using agg, which is non-GUI backend, so cannot show the figure.

Do I have to install something else for it to work?

1 Answer 1

8

Yes, you have to. The accepted answer to this similar Stack Overflow question suggests that the problem is that tkinter is not installed. You can install it using:

sudo apt install python3-tk
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .