6

I tried reading the contents of a BIOS EEPROM Chip saved in a file called dump.bin. I also tried opening a file called coreboot.rom containing a Coreboot image. In both cases this error occurred: I used Bless Hexeditor to open the file, but I only got these ASCII squares with four numbers in it, describing which ASCII value the characters have. bless hex editor Most of them are 0046-squares, which equivalents to letter "F". This goes well with what I already know about the contents of dump.bin.

How can I make Bless Hexeditor show me the real byte values as integers/characters? I didn't find any resource regarding this topic. I tried reinstalling Bless with Synaptic package manager, but it didn't help.

I use Ubuntu 20.04.2 LTS, Xubuntu flavor. I use xfce4 desktop but I also have some GNOME stuff installed. ls /usr/bin/*session returns

/usr/bin/dbus-run-session
/usr/bin/gnome-session-custom-session
/usr/bin/gnome-session
/usr/bin/xfce4-session

Edit: When I run bless in terminal, I get the following errors before bless starts:

Could not find a part of the path '/home/user/.config/bless/plugins'.
Could not find a part of the path '/home/user/.config/bless/plugins'.
Could not find file "/home/user/.config/bless/export_patterns"

When searching for these errors, I found this thread saying that the errors don't actually mean sth.

Edit2: I found that GHex works just fine, so I'll probably stick with that. It's weird though that a friend of mine using Bless with Ubuntu 20.04 doesn't have this problem.

10
  • 1
    What are your Ubuntu version and desktop environment?
    – N0rbert
    May 30, 2021 at 16:49
  • 2
    Can't reproduce on 20.04 LTS - MATE, Gnome, Xfce. Maybe fonts issue. Do you have any interesting font-related output if you run bless from terminal?
    – N0rbert
    May 30, 2021 at 17:47
  • 3
    I just tried bless on 18.04 from repository and it seems buggy. It displays the characters correctly, but when exiting the program, it is terminating abnormally. I would look into alternative - ghex or wx hexeditor (appimage).
    – kukulo
    May 30, 2021 at 17:52
  • 1
    I agree with @N0rbert comment, it seems to be a font issue.I would add that Bless is based on GTK# and launched through Mono. Do you another tool that depends on Mono to test it? You may see list of packages depending on mono with: apt-cache rdepends mono-runtime
    – user.dz
    May 30, 2021 at 20:06
  • 1
    Also have the same issue. Linux mint 20.2 fresh(ish) install. Oct 24, 2021 at 8:17

1 Answer 1

3

Converting my comment and @user.dz's comment to an answer as requested.

As per this bug report, the issue is caused because the latest version of an upstream library (pango) deprecated the use of certain fonts, causing breaking changes to older programs which used these fonts. This mainly affects users on Ubuntu 20.04, which uses the upgraded pango libraries and the 0.6.0 bless version.

The bug has been fixed in the latest bless releases on github.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.