4

Environment:

  Motherboard: X570 AORUS ULTRA
  CPU: AMD Ryzen 9 3950X 16-Core Processor
  Distro: Ubuntu server + xfce4
  Ubuntu version: 21.04
  Kernel version: 5.11.0-17-generic
  Wifi hardware: Intel Corporation Wi-Fi 6 AX200 [8086:2723] (rev 1a)
  Boot: Single boot (No Windows. Just Ubuntu). Fast book disabled in bios.

This is a clean install. No issues during install.

The problem I am running into is that, although the OS detects the hardware, the link seems to be DOWN.

$ ip a

3: wlp6s0: <BROADCAST,MULTICAST> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
    link/ether xx:xx:xx:xx:xx:xx brd ff:ff:ff:ff:ff:ff

There are many similar messages on the net:

Intel Wi-fi 6 AX200 adapter not found on Ubuntu 20.04

Cannot get an Intel Corporation Wi-Fi 6 AX200 (rev 1a) to work with Mate 20.04

Will intel Wifi AX200 work with ubuntu 20.4 in WIFI 6 mode

However, I already have incorporated all the recommendations:

  1. Disabled fast boot in bios
  2. No dual boot
  3. Have the latest x570 bios firmware
  4. Have a newer Linux kernel
  5. Have the latest Intel AX200 wifi driver (/lib/firmware/iwlwifi-cc-a0-59.ucode)

I still cannot figure out how to get the wifi to work. Please help.

Here is some useful info:

$ sudo dmesg | grep iwl
iwlwifi 0000:06:00.0: enabling device (0000 -> 0002)
iwlwifi 0000:06:00.0: api flags index 2 larger than supported by driver
iwlwifi 0000:06:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 89.3.35.22
iwlwifi 0000:06:00.0: loaded firmware version 59.601f3a66.0 cc-a0-59.ucode op_mode iwlmvm
iwlwifi 0000:06:00.0: Detected Intel(R) Wi-Fi 6 AX200 160MHz, REV=0x340
iwlwifi 0000:06:00.0: base HW address: 70:9c:d1:51:95:91
iwlwifi 0000:06:00.0 wlp6s0: renamed from wlan0

$ lshw -C network
WARNING: you should run this program as super-user.
  *-network                 
       description: Wireless interface
       product: Wi-Fi 6 AX200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:06:00.0
       logical name: wlp6s0
       version: 1a
       serial: xx:xx:xx:xx:xx:xx
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.11.0-17-generic firmware=59.601f3a66.0 cc-a0-59.ucode latency=0 link=no multicast=yes wireless=IEEE 802.11
       resources: irq:175 memory:fc800000-fc803fff

$ lsmod | grep iw
iwlmvm                421888  0
mac80211             1028096  1 iwlmvm
iwlwifi               376832  1 iwlmvm
cfg80211              892928  3 iwlmvm,iwlwifi,mac80211

$ lspci -nn | grep Network
06:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX200 [8086:2723] (rev 1a)
07:00.0 Ethernet controller [0200]: Intel Corporation I211 Gigabit Network Connection [8086:1539] (rev 03)


3
  • Can you get temporary internet connectivity by ethernet or tethering? My proposed solution will depend on this.
    – chili555
    Commented May 30, 2021 at 15:39
  • Thanks chili555. This is what I am doing temporarily. However, I do need a longer term solution.
    – Peter
    Commented May 30, 2021 at 17:46
  • This was the sole reason for me last year removing ubuntu from my PC, i thought id give it a go again, as i thought it would be fixed...might take it off again. Silly me Commented Dec 20, 2023 at 11:46

3 Answers 3

3

By default, Ubuntu server edition does not include the required packages wpa_supplicant and wireless-tools. To install them, with a temporary working internet connection by tethering, ethernet or whatever means possible, do:

sudo apt update
sudo apt install wpasupplicant wireless-tools

Several dependencies will also be installed.

Next, edit your netplan file to add your exact details. For servers, I recommend a static IP address so that you can easily SSH and FTP into it. Please be certain to select an address outside the DHCP pool in the router.

Next, remove your not-working netplan file:

sudo rm /etc/netplan/*.yaml

And create a new file.

sudo nano /etc/netplan/01-netcfg.yaml

I suggest:

network:
  version: 2
  renderer: networkd
  wifis:
    wlp6s0:
      dhcp4: no
      dhcp6: no
      addresses: [192.168.0.150/24]
      gateway4: 192.168.0.1
      nameservers:
        addresses: [192.168.0.1, 8.8.8.8]
      access-points:
        "network_ssid_name":
          password: "**********"

Of course, substitute your exact details here.

Please note that the network SSID name and the password are enclosed in quotes. Netplan is very specific about spacing and indentation. It accepts spaces but not tabs. Proofread carefully twice. Save (Ctrl+O followed by Enter) and exit (Ctrl+X followed by Enter) the nano text editor.

Follow with:

sudo netplan generate
sudo netplan apply 

If there are no mistakes, you should connect immediately and automatically on boot.

0

For me, this solved the issue (cited from the source below):

# run this to determine which firmware the kernal is looking for
modinfo iwlwifi | grep iwlwifi-cc

# example output:
# firmware:       iwlwifi-cc-a0-50.ucode

# go https://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git/tree/ and download the firmware

# copy file to /lib/firmware
sudo cp ~/Download/iwlwifi-cc-a0-50.ucode /lib/firmware

# reboot
sudo reboot

# check that firmware was loaded
sudo dmesg | grep iwlwifi | grep version

# example output
# [    4.566709] iwlwifi 0000:05:00.0: loaded firmware version 50.3e391d3e.0 op_mode iwlmvm

https://gist.github.com/mixxen/339846df6f316416336d038090a3c848

2
  • Not working for me. Can anyone help?
    – SirOgm
    Commented Sep 19, 2022 at 18:37
  • What should we do if iwlwifi does not seem to produce any dmesg output?
    – SirOgm
    Commented Sep 27, 2022 at 19:23
0

If you don't see your WiFi,(specially if you are on a fresh install) check if your fast boot is turned off in bio. If that didn't work, and you are in dual boot, you need to go into windows at less 1x then reboot, then your WiFi will reappear

2
  • MY SAFEBOOT is turned off i still get - network unclaimed on my wifi adaptor. The moderator keeps deleting my posts/comments Commented Dec 21, 2023 at 11:13
  • @user1673554 Are you dual booting? if yes, even though this may sound funny/unreasonable, login to you Windows and disconnect from internet and remove the "Connect automatically". For some reason Windows keep the connection (probably because it wants to update while your PC is off. Linus Tech Tips has a video on why, i wont get deep into it). After disconnecting from internet from Windows, boot in your Ubuntu and it should be fixed, if not, its driver issue.
    – Ali
    Commented Dec 25, 2023 at 8:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .