1

Today I foolishly gave in to upgrade requests to 12.04 from 11.10 and now Im having a lot of issues with the unity interface where the previous version worked seamlessly.

After boot the following services are running:

  • /usr/bin/compiz-decorator
  • compiz
  • unity-window-decorator
  • unity-panel-service
  • unity-application-daemon
  • unity-music-daemon

The main problems are :

  1. Every 30seconds or so all windows and menus disappear for a few seconds leaving just the background image

  2. If the mouse goes over the task bar items on the top right of the screen it causes a segmentation fault of
    unity.glib.dbusproxy "unity.glib.dbusproxy GLibDBusProxy.cpp:257 cannot call method SetViewType proxy /com/canonical/unity/lens/commands does not exist
    Window boarders disappear and I can't move or resize windows

  3. If the mouse goes over the app menu on the left I get a compiz segfault
    composite sync not supported
    compiz[7361]: segfault at 0 ip ... sp ... error 4 in libunityshell.so[...]
  4. The computer will not shut down when I select "shut down" from the task bar on the top right.

Ive tried a lot of different commands to try and fix this based on other related questions:

  1. unity --reset
  2. unity --replace
  3. compiz --replace
  4. metacity --replace&unity
  5. compiz-decorator
  6. gconftool-2 --recursive-unset /apps/compiz-1
  7. gconftool-2 --recursive-unset /apps/compizconfig-1
  8. rm -rf ~/.gconf* ~/.gnome* ~/.metacity ~/.compiz ~/.conf*
  9. disabling animation features etc... in gconf-editor but any changes cause a segmentation fault
    "gconf-client-lookup assertion failed"
  10. changing CCSM settings (compiz config settings manager)
  11. reverting to gnome-session-fallback but it's not possible due to a dependency issue
    "gnome-session : Breaks: unity-2d (< 5.4~) but 5.2.0-0ubuntu1 is to be installed E: Error"

So Ive made zero progress. Any suggestions appreciated :)

I have an Intel atom netbook with 945GSE Express integrated graphics controller

-Damian

4
  • Before any more tweaks,do a clean back up of your valuable data and continue to recover it to its past.I would suggest a clean install as your upgrade process has failed.
    – beeju
    May 9, 2012 at 0:45
  • Adding to what @beeju said, I would also suggest you do a backup at once you restore to that state that you what. The default backup program is a good one. May 9, 2012 at 0:59
  • Thanks guys. I have my personal data backed up on another drive. I will try a fresh install this evening. What is the default backup program? Is there a way to store the current state of my system so that if some update fails I can just return to its previous working state?
    – user61941
    May 9, 2012 at 8:40
  • possibly helpful, though not a duplicate: askubuntu.com/questions/126724/…
    – Jjed
    May 9, 2012 at 9:18

1 Answer 1

1

you should sign up for the known bug here:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/993189?comments=all

Unity2d should work for you with no trouble at all

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .