1

I am attempting to automount an nfs share on my server to my local machine using fstab. I have a few shares from the server that mounts on the local machine. I am sharing all the drives that is mounted on the server in the /media folder to /mnt/server on local machine. They all mount prefectly and works as expected. I also want to automount to the apache web server /var/www folder on the server. manual mounting works fine, but I am unable to make an automount work. fstab for these mounts looks as follows:

server:/media    /mnt/server   nfs4             rw,_netdev      0 0
server:/var/www  /mnt/var        nfs4            rw,_netdev       0 0

I don't have much more info unless someone can point me to a log where I can find more info, the error that dolphin shows is "An error occurred while accessing 'Home', the system responded: mount.nfs4: failed to prepare mount: Operation not permitted". I have tried to change the nfs server share path but same error as always.

My setup is server: Ubuntu 20.10 samba and nfs active, workstation: Kubuntu 20.04 only nfs active.

Thanks

1 Answer 1

0

I resolved the error, I also use webmin to manage both server and workstation via the webui. to resolve I navigated to the disk and network filesystems module of webmin and edited the nfs share for the /var/www automount, in the settings for the share I set Allow users to mount this filesystem to yes and saved. then clicked on share in dolphin and it opened as the /media shares do. I did not have to do this for the /media shares so somewhat unsure of why this happened, if anyone can share some info it would be appreciated.

Thanks

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .