My problem is that after choosing Unity 3d at login the Unity 2d loads, Even though my graphics drivers seems to be working fine. Unity 3d is possible to load by following commands:

ps aux | grep -i unity-2
killall /usr/bin/unity-2d-spread
killall unity-2d-shell
killall unity-2d-panel

Then Unity 3d works fine (if I don't kill Unity 2d, I get 2 panels overlapping). How can I make unity 3d to load when I login?

I'm using Ubuntu 12.04, Linux kevin 3.2.0-24-generic-pae #37-Ubuntu ... i686 i686 i386 GNU/Linux

edit: the output of unity support test can be seen here:

$ /usr/lib/nux/unity_support_test -p
OpenGL vendor string:   NVIDIA Corporation
OpenGL renderer string: GeForce Go 7300/PCIe/SSE2
OpenGL version string:  2.1.2 NVIDIA 295.40

Not software rendered:    yes
Not blacklisted:          no
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       no
  • 1
    You said "graphics drivers seems to be working".So you are not sure about it.Ubuntu 3D needs full supported graphics to work well.I think driver is missing and try run the "Additional drivers" from menu and have a look. – beeju May 9 '12 at 0:00
  • Have you tried pasting /usr/lib/nux/unity_support_test -p into a terminal to see if the drivers are really working? – Mark Paskal May 9 '12 at 7:28
  • It looks that you are right. I will put the output of test to the question above, it says "blacklisted". I have installed the additional drivers after installation of system. – Vojta May 9 '12 at 9:27
  • It looks like the similar problem is here, but with no solution so far. – Vojta May 11 '12 at 14:56

I had previously chosen to install the proprietary Nvidia drivers, both the 'version current' and 'version current-updates'.

I have:
Ubuntu 12.04 with all the latest updates,
Nvidia Geforce GTX 460

I was making sure to choose 'Ubuntu' (instead of 'Ubuntu 2D') during logging in, yet I was still getting Unity 2D. After some research, I fixed this problem for myself by:

  1. Removing the Nvidia proprietary drivers:

    • System Settings -> Additional Drivers (Wait a minute while it loads,)
    • Choose each driver and choose 'Remove' (if the option exists,)
  2. Reboot.

    • Amazingly, the default drivers worked perfectly, (even with my dual monitors!)

Now when I choose 'Ubuntu' (instead of 'Ubuntu 2D') during logging in I actually get Unity 3D!

  • I have tried your solution and I got Unity 3D working, Thanks, but I feel bad that I couldn't get nvidia to work :( – Rakesh Sankar Oct 5 '12 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.