0

I have a folder showing a lock icon. I can't execute any programs that are in this folder.

I have tried to run the commands:

chmod 777 folder_name

and

sudo chown -R USER:HOME folder_name

When I do so I get as a response that it is a read-only file system.

How can I solve this?

0

1 Answer 1

0

From the Information you gave, it seems the Drive you're trying to read from might be mounted without write or execute access.

To do that you can set that in gnome-disks by selecting your drive, selecting the partition you want to mount and clicking on the settings icon. There you can edit the mount options. Uncheck "User Session Defaults" and in the textfield containing nosuid,nodev,nofail,x-gvfs-show you simply add rw,exec to enable read/write and execution access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.