5

This is my first post on here, so hope someone will be able to help me. I'm also fairly new to linux so need some guidance as well.

I have recently bought an asus rog zephyrus g14(latest one) and installed ubuntu 21.04 on there and the wifi is not working. I am also dual booting with windows 10

It doesn't display under settings in the gui, it does show up in lspci as Network Controller: MEDIATEK Corp Device 7961.

I tried looking almost everywhere for drivers but no luck.

Secure boot is disabled and there is now power management tab under device manager for the wireless in windows

I am really hoping someone can help me

See below output of lswh -C network and lspci

*-network UNCLAIMED       
       description: Network controller
       product: MEDIATEK Corp.
       vendor: MEDIATEK Corp.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm cap_list
       configuration: latency=0
       resources: iomemory:fe0-fdf iomemory:fe0-fdf iomemory:fe0-fdf memory:fe20300000-fe203fffff memory:fe20400000-fe20403fff memory:fe20404000-fe20404fff


02:00.0 Network controller: MEDIATEK Corp. Device 7961

2
  • It's interesting that it's the WiFi that you're having difficulty with as the ROG G14 is notorious for having a very particular set of installation steps. Either way, can you update your question to include a copy/pasted output of sudo lshw -C network and lspci? This will contain specific information about your network hardware. The Mediatek device you mentioned is not the wireless card, as most ROGs ship with an Intel AX200-series device. Sharing the output of the above commands will allow for a confirmation and — ideally — a specific recommendation to get your WiFi working 👍🏻
    – matigo
    May 26 at 13:15
  • I got Rog Zephyrus g15, I had same problem. Upgrading to Kernel v13 worked for me. V12 didn't worked for me (Ubuntu v21) Aug 18 at 21:14
4

The problem is fixed by upgrading linux kernel to 5.12

As mentioned by Maciej, linux kernel 5.12+ has support MEDIATEK 7961. But since Ubuntu 20.04 has libc6 v2.32, I ran into issues while trying to upgrade linux kernel to 5.12.

Ubuntu 21.10 runs on kernel version 5.13, so on this and all newer versions of Ubuntu, the driver works without any changes. To use an older version of Ubuntu, you'll have to upgrade the kernel manually (see here for a good tutorial).


Edit: After a while it stopped working again even with mt7921e driver. Following this suggestion, I powered off the laptop (instead of rebooting it) and unplugged the power cable for a few minutes. Then the Wi-Fi adapter magically appeared. Related issue in the mt76 repo: click.

4
  • Does touchpad work for you?
    – lovesh
    Jul 13 at 10:09
  • How did you update the kernel? Also, did you have any issues with safe boot after upgrading the kernel?
    – 2br-2b
    Jul 15 at 1:55
  • 1
    My touchpad works fine. I have disabled safe boot. To update the kernel, followed Maciej's answer exactly.
    – Roman
    Jul 15 at 10:45
  • This response is wrong. The linux kernel 5.12+ supports mediatek 7921, not mediatek 7961. The 7961 device does not work on 5.13.0-16. Sep 11 at 0:59
1

I won with this issue. Driver for linux for this adapter is available in linux kerner 5.12+. I downloaded mainline, download and switch kernel to 5.12+ and that's all. I lost whole weekend for that but now i have device with wifii :D

  1. sudo add-apt-repository ppa:cappelikan/ppa
  2. sudo apt update
  3. sudo apt install mainline

Run mainline (not from command, click windows button and write mainline, then click on it) Select on 5.12.8 and click install. After that reboot and you'll be surprised :)

-1

With pop os 20.04, upgrading kernel to 5.12.14 (stable version) worked for me.

(@maciej-cebula's solution worked)

Not the answer you're looking for? Browse other questions tagged or ask your own question.