1

I am using Ubuntu Studio 20.04 and trying to change the default browser from Firefox to Brave.

Used the default applications settings and simply changed the default browser to Brave.

Works without any problem if I press the Home key on my keyboard. Also no issues at all when trying to open a link from apps such as Tutanota or VirtualBox etc.

However, when I try to open a link from Evolution Mail or Thunderbird or even gnome-calculator, the link gets opened in Firefox.

If I uninstall Firefox, then links from Evolution and Thunderbird are opened in Brave - no issues.

Changed all the mime-type settings to Brave browser as the preferred application but still no luck with this.

Anyone has any suggestion?

Thanks.

0

Solution was to

  1. install gnome-control-center
  2. run 'gnome-control-center default-applications'
  3. Change the Web from Firefox to Brave (in my particular case)

Not 100% sure, but I guess the issue is related to gnome-based apps which take the default applications from the gnome-control-center rather than from xfce settings. Would appreciate if anyone can comment on this. Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.