6

I have gnome-disk-utility installed. It mounts a secondary hard drive I have, but it does not do it with write or execute permissions.

How do I setup gnome-disk-utility to mount a hard drive with read, write, and execute permissions?

enter image description here

Per this other Ask Ubuntu question (https://askubuntu.com/a/769465/461996) it seems I should add uid=1000,noauto,users to the argument list. I tried this, but still I do not have write or execute permissions.

5 Answers 5

8

The whole purpose of a GUI disk manager is to avoid this trouble. This is why Linux is not used by my mother.

Add the following to your mounting options.

uid=1000,gid=1000

Here is the screenshot from the app. enter image description here

1

I fixed my permission issue on a partition-mount by clicking that icon where you pick "Edit mount options" but I chose "Take Ownership" instead.

And I have these options: nosuid,nodev,nofail,x-gvfs-show,rw,exec

1
  • Tks, that's exacly what I was looking for. This answer should be marked as the best as it does perfectly what was asked.
    – thiggy01
    Jun 21, 2023 at 22:03
0

Alright. This isn't a complete answer, but it works.

Based off another answer, I tried adding users assuming all users are in that category. I guess this is only the case for users that have no other group (https://unix.stackexchange.com/a/326782/132794)

I do not know how to add a permission that makes it so any user can have read/write permissions on this mount. So that's why this is not yet a complete answer.

Anyways, the trick was uid=1000. You can get your user id with echo $UID or just id.


Further, if you get your username with whoami, you can see what groups you are in with groups [username]. Perhaps one of these groups is applicable to all users? Perhaps not.

0
0

To achieve full permissions, you need to add rw,exec. That will allow read/write and execution access.

0

The man page for gnome-disk-image-mounter (which is what is being used by the Gnome Disk Utility to mount the images) says the following:

By default the disk images are attached read-only, use the option --writable to change this.

So running gnome-disk-image-mounter --writable then selecting the image to mount mounts it writable. Adding the other command line options did not worked for me using version 3.36.3

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .