1

after several attempts I was not able to install Shank.I've download the bin and .deb (for 64bit architecture) files. The bin shows this message on launch: "No such file or directory". The Deb not installed correctly. If someone managed to find a solution or workaround to install this game I hope will help me too. Thanks for your time and support.

0
2

I've found a solution: by installing the deb for 32 bit I realized I was missing some libraries (in addition to ia32-libs and libc6). I first solved this problem by giving this command: sudo apt-get install -f.

Then I got another error: Message: SDL_GL_LoadLibrary Error: Failed loading libGL.so.1

Obviously, these libraries were properly installed. Without going into details I had to link the libraries by hand. I realized then that could also an easier solution through Synaptic install the following packages: libgl1-mesa-glx:i386, libgl1-mesa-dri:i386.

After that the next problem was the black screen while playing, which I solved by replacing the executable in /Shank/bin with this: http://treefort.icculus.org/smb/smb-linux-mesa-hotfix-test.tar.bz2.

I hope it will be useful to someone. If you need more help or more details please feel free to contact me.

2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.