I have configured 4 workspaces in gnome Classic without effects, and this seems to work. When I log in with gnome classic with effects (compiz) I also see 4 workspaces in the panel but when I click on the second workspace just the background image is shown. There seems no way out of this background only Workspace other then Ctrl-Alt-F1 and restarting the window manager.


8 Answers 8


I initially had the same problem with workplace switching and only the background showing in Gnome classic, but the fix to Alt-Tab does not switch also fixed this - i.e. install compizconfig-settings-manager, and enable "application switcher".

Then if you wish to customize the arrangement of the workplaces from 2x2 to say 4x1, you can do that under Applications -> system tools -> preferences -> compizconfig settings manager -> general -> General options -> Desktop size -> horizontal virtual size = 4, vertical virtual size = 1.

  • 1
    This worked perfectly in Gnome Classic and Ubuntu 12.04.
    – Marquez
    Feb 14, 2013 at 23:03
  • Actually I think there is a real problem with the workplace switcher applet and the window manager miscommunicating, both trying to manage the number of workplaces independently. What worked for me is doing right-click on the workplace swither applet, click the pop-up "Preferences", and set to 1 (yes!) both the number of rows (at the point "show all workspaces in"), and the number of workspaces. The effect is paradoxically that the applet shows the number of workplaces and rows set by the compizconfig settings manager manipulation above and switching workspaces works (for me). Jun 30, 2014 at 8:28

Yeah, almost definitely something with effects. In my case, I had the Desktop cube enabled, rather than the desktop wall (I like the cube better!). I set the number of desktops to 4x1x1 as the comment above stated, but that didn't fix the problem by itself.

After I re-enabled the desktop wall, and disabled all the cube plugins, everything works as it should...sigh...if cinnamon would quit crashing I'd switch back to that...at least I could have my cube back :)



The issue remains but I have made progress on a workaround. The core issue is that you are booting up with 4 desktops but compiz wants you using 4 viewports. One workaround is to set the number of desktops to 1 and let compiz take over.

sudo apt-get install wmctrl

Then run

wmctrl -n 1

when you first log in using your method of choice (startup applications or editing /etc/rc.local would be a few options).

This will get you to the "1 desktop, 4 viewports" mode so you can skip doing it manually, as described below

Original Message

I have been fighting this issue as well, and although I do not yet have an answer I do have some notes and have made some moderate progress.

It appears there are two competing workspace managers in play. When first booting I will always have four workspaces (1x4) and hovering each workspace will declare a unique number (for example 'Current workspace: "Workspace 2"'). Clicking on workspaces 2-4 will result in the above mentioned behavior, the panels vanish and you are left with only a background image and seemingly no way to return to workspace 1.

I have found that initiating the run window Alt+F2 will bring you back to workspace 1, so you do not need to reboot.

If you right click on the workspace switcher, select preferences, and change the number of workspaces to 1, compiz will take over, and visually you will go from 2 workspaces "down" to 4 (assuming you have compiz set to four workspaces as I do). Now however hovering any of the workspaces will show as "Workspace 1". All compiz effects and features appear to work at this point. I have played with different workspace configurations in compiz, and so long as that "primary" workspace manager is set to 1 the settings come through; at two or more it overrides compiz and only workspace 1 is usable.

I have attempted to set the number of workspaces to 1 via Conf Editor /apps/metacity/general/num_workspaces and though the value is saved, it does not have an effect during reboots.

I do notice that I am unable to drag a program between workspaces. Context menu switching (Move to Workspace Right for example) works, but basically the workspace switcher in the corner recognizes all four of compiz's workspaces as sitting inside "one workspace" so dragging things around does not work.

So for me, upon first log in, I right click workspace switcher, preferences, set workspaces to 1, and from there I'm good until reboot. A bit of a pain but I'm living with it while still searching for a better solution.

Hope this info helps

  • Updated answer with a decent workaround Feb 8, 2013 at 0:45

Seems like the quick answer is to try Gnome Classic (no effects). Something in effects breaks workplace switcher.

Now, if they could only do classic window AND application menus along with the option of a classic workspace switcher AND Unity HUD, life would be better.

  • I tried again different settings and now i am happy when setting the following in compizconfigsettings manager general options. horizontal virtual size: 4 vertical virtual size: 1 Number of Desktops: 1 May 29, 2012 at 18:15

The fix in post 2 works well.

Just to clarify for those not familiar with Gnome classic startup applications:

Click on the cogwheel shaped power switch on the top right (usually) - the one that's normally used to shut down, restart or log out, and select Startup Applications. Click on "Add" and type in wmctrl -n 1 in the "Command box" and this will do the trick on every start-up/login.

Another way is to add the line in ~/.gnome2/session-manual file. I didn't do it this way in case they corrected the problem later on: it's easier to remove the fix in future with above, as I personally would forget where the hell the session-manual file was as time goes on...


I struggled a bit with this myself and eventually it was much easier and quicker to reset the settings to default via preferences in compiz and just re-enable workspace via system after enabling the unity plugin, some work in configuring effects to your liking i know but it will save you all the time searching for settings.


This is still an existing bug in 16.04,

using the right click shortcut does not work, but

the following keyboard shortcut does work:

Ctrl+Alt+Shift+<Arrow Key>


If you are using Compiz then go to ccsm then select General Options. There's a Desktop Size tab. Select that and you can set the Horizonal Virtual Size there.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.