5

I try to make my USB Bluetooth dongle work, but it does says, that there's no firmware

lsusb output:

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 0bda:8771 Realtek Semiconductor Corp. Bluetooth Radio
Bus 001 Device 004: ID 413c:2113 Dell Computer Corp. KB216 Wired Keyboard
Bus 001 Device 003: ID 413c:301a Dell Computer Corp. Dell MS116 Optical Mouse
Bus 001 Device 007: ID 2717:ff80 Xiaomi Inc. Mi/Redmi series (RNDIS)
Bus 001 Device 002: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

dmesg output for command sudo dmesg | grep -i bluetooth

[    2.146047] usb 1-8: Product: Bluetooth Radio
[    3.386019] Bluetooth: Core ver 2.22
[    3.386031] Bluetooth: HCI device and connection manager initialized
[    3.386034] Bluetooth: HCI socket layer initialized
[    3.386035] Bluetooth: L2CAP socket layer initialized
[    3.386038] Bluetooth: SCO socket layer initialized
[    3.443247] Bluetooth: hci0: RTL: examining hci_ver=0a hci_rev=000b lmp_ver=0a lmp_subver=8761
[    3.444088] Bluetooth: hci0: RTL: rom_version status=0 version=1
[    3.444089] Bluetooth: hci0: RTL: loading rtl_bt/rtl8761b_fw.bin
[    3.445239] bluetooth hci0: Direct firmware load for rtl_bt/rtl8761b_fw.bin failed with error -2
[    3.445242] Bluetooth: hci0: RTL: firmware file rtl_bt/rtl8761b_fw.bin not found
[    8.604909] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[    8.604912] Bluetooth: BNEP filters: protocol multicast
[    8.604915] Bluetooth: BNEP socket layer initialized

I tried to find the firmware, for Ubuntu 21.04, but there's only for Ubuntu 20.04 (https://gist.github.com/rometsch/dfd24fb09c85c1ad2f25223dc1481aaa). Therefore I'd like to ask for a potential solution.

2 Answers 2

10

The firmware for rtl8761b is missing in your Linux distribution if you see these errors:

Direct firmware load for rtl_bt/rtl8761b_fw.bin failed with error -2
firmware file rtl_bt/rtl8761b_fw.bin not found

Execute these commands to install the missing firmware:

cd /tmp
# Fetch rtl8761b_config and rtl8761b_fw from https://github.com/Realtek-OpenSource/android_hardware_realtek
wget https://raw.githubusercontent.com/Realtek-OpenSource/android_hardware_realtek/rtk1395/bt/rtkbt/Firmware/BT/rtl8761b_config
wget https://raw.githubusercontent.com/Realtek-OpenSource/android_hardware_realtek/rtk1395/bt/rtkbt/Firmware/BT/rtl8761b_fw
mv rtl8761b_config /lib/firmware/rtl_bt/rtl8761b_config.bin
mv rtl8761b_fw /lib/firmware/rtl_bt/rtl8761b_fw.bin
sudo modprobe btusb
sudo systemctl start bluetooth.service
hciconfig -a # will show that the bluetooth-device is up

If you are looking for a more comfortable solution, here's a similar, script-based solution that automatically installs missing bluetooth-firmware, including rtl8761b: https://unix.stackexchange.com/a/643707/88252

3
  • 1
    These blobs are also available from kernel.org git.kernel.org/pub/scm/linux/kernel/git/firmware/… Commented Sep 7, 2022 at 23:10
  • 2
    Thanks for your answer. I had to rename rtl8761b* to rtl8761bu to get it working with Armbian 22.08 Jammy.
    – LA_
    Commented Sep 22, 2022 at 11:11
  • 1
    For anyone else running into issues with Kernel 5.15.0 in addition to downloading the firmware from realtek I also needed to name those files rtl8761bu_config.bin and rtl8761bu_fw.bin on my system to get things working.
    – Peter
    Commented Jan 1, 2023 at 10:27
2

I just spent the better part of a day on this. The firmware in kernel.org doesn't work and renaming/symlinking from rtl8761b_fw.bin and rtl8761b_config.bin doesn't work.

Anyway, I made a quick deb file (I bought a couple of adapters and probably need to install this on most of the computers here so it was worth my while): https://www.dropbox.com/scl/fi/zf19jwjhg996xy5rsrnu7/rtl8761bufw.deb?rlkey=tb9b1y6b3vrkogvl9gafpttgx&dl=0

I'll probably share it in a better way at some stage (it's silly as it is). I can't find the license terms with which these firmware files have been released so I've described it as non-free.

Anyway, it's an easy way to install (and uninstall) the firmware (If you're curious as to what's in there, you could always use ar to extract the files).

1
  • 1
    Holy crap this worked great for me. Are these firmware files straight from realtek? Why do they work better than the ones in linux-firmware?
    – cam8001
    Commented Apr 1 at 8:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .