Since I have installed ubuntu 20.04 I am facing problems with my bluetooth headset microphone not detected by the system. My headset worked perfectly with Windows. Also, I am not able to switch to HFP from AD2P in ubuntu. So my final thought is to remove pulseaudio and install pipewire hoping that it will solve my problems.

Can anyone please provide the steps to do the same? I have searched it quite a few times but not able to get to the correct steps.

Thanks a lot!


9 Answers 9


I was facing the same issue with Oneplus Wireless Z Bass edition. My headset microphone was not detected by PulseAudio and the problem is that my headphones don't have HSP profile, only HFP profile. After trying for 2 days, I came to the solution of replacing PulseAudio with Pipewire sound server, which supports HSP, HFP and A2DP by itself. So there will be no need to install any other utility like ofono, phonesim. Also, to be noted that my problem wasn't resolved even after following all the steps to configure ofono in PulseAudio. So I came up with the steps to replace PulseAudio with PipeWire.

Here is the detailed article I have written to resolve this problem, the steps of which I'm also adding here. You can follow it and most probably be able to solve your problem.

Bluetooth headset microphone not detected

Open your terminal and follow these steps:

  1. We will use a PPA for adding Pipewire to Ubuntu 20.04, which is maintained regularly:

    sudo add-apt-repository ppa:pipewire-debian/pipewire-upstream
  2. To update the PPA packages in your system do:

    sudo apt update
  3. Install the package:

    sudo apt install pipewire
  4. There is also a dependency needed to be installed with Pipewire, otherwise you will face the issue of “Bluetooth headset won’t connect after installing pipewire”. Install the dependency by:

    sudo apt install libspa-0.2-bluetooth
  5. Now, to install the client libraries:

    sudo apt install pipewire-audio-client-libraries
  6. Reload the daemon:

    systemctl --user daemon-reload
  7. Disable PulseAudio:

    systemctl --user --now disable pulseaudio.service pulseaudio.socket
  8. If you are on Ubuntu 20.04, you also need to “mask” the PulseAudio by:

    systemctl --user mask pulseaudio

I am not sure but, if possible, you can try to run this on other versions too.
9. After a new update of Pipewire, you also need to enable pipewire-media-session-service:

   systemctl --user --now enable pipewire-media-session.service
  1. You can ensure that Pipewire is now running through:

    pactl info

    This command will give the following output, in Server Name you can see:

    PulseAudio (on PipeWire 0.3.28)

    Things should be working by now and you can see your microphone.

If it doesn’t show up, then try restarting Pipewire by this command:

systemctl --user restart pipewire

Edit: You need to uninstall ofono and phonesim from your system if you have them installed.

sudo apt remove ofono
sudo apt remove ofono-phonesim

If it’s still not showing your microphone, you can try rebooting once and remove and pair your Bluetooth device again to check if it works now.

I hope I have helped you solve your problem.

If you want to rollback all the changes we did, you can do it by using:

systemctl --user unmask pulseaudio
systemctl --user --now disable pipewire{,-pulse}.{socket,service}    
systemctl --user --now enable pulseaudio.service pulseaudio.socket
  • I've been having the same problem with my headset not being detected on Ubuntu 21.04. I tried this solution, but now there is no HSP/HFP option under for the headset in the sound settings. There is only A2DP Sink with codec AAC and A2DP with codec SBC. Any ideas as to why this is?
    – BenM
    May 23, 2021 at 14:00
  • Did you try restarting you system? And also can you show me your output of : pactl info Also, you need to try restarting pipewire, unpair and pair your device.
    – 1nfern0
    May 23, 2021 at 14:03
  • Yes, I tried restarting my system. I also restarted Pipewire. The output of pactl info: Server String: /run/user/1000/pulse/native Library Protocol Version: 34 Server Protocol Version: 35 Is Local: yes Client Index: 83 Tile Size: 65472 User Name: ben Host Name: ben-desktop Server Name: PulseAudio (on PipeWire 0.3.28) Server Version: 14.0.0 Default Sample Specification: float32le 2ch 48000Hz Default Channel Map: front-left,front-right Default Sink: bluez_output.AC_12_2F_24_03_B1.a2dp-sink Default Source: bluez_output.AC_12_2F_24_03_B1.a2dp-sink.monitor Cookie: 0e10:4a04
    – BenM
    May 23, 2021 at 14:06
  • I am assuming your headset works perfectly fine with Windows and Android/Mac. Am i correct?
    – 1nfern0
    May 23, 2021 at 14:08
  • 1
    I have already tried switching the profile from Bluetooth Manager, but the HSP/HFP profile wasn't listed there either. However, I found the problem. I had tried using ofono to solve this issue a few weeks ago following the same AskUbuntu post you mentioned in your article, and I realised that I still had ofono installed. I just had to uninstall ofono, and now my microphone works perfectly using Pipewire. Thanks for all your help. I've been trying to get my mic to work on Ubuntu for quite a while. :)
    – BenM
    May 23, 2021 at 14:35

To add to 1nfern0's answer, pactl info was giving me a connection failure after following all the steps. I got around it by running: systemctl --user --now enable pipewire pipewire-pulse.

You may also need to restart your system once.


The answers above were important, there is one other thing that is possible which is that you have an old config file in /etc/pipewire/pipewire.conf which will prevent pipewire from properly working, I removed the entire /etc/pipewire directory and reinstalled pipewire and pipewire-pulse to resolve the issues and now things work.

  • 1
    In my case I have been installing earlier by another guides and it didn't work anything. I just followed the answer and removed. It works now.
    – Adrug
    Jan 3, 2022 at 13:48

After completing the steps described in 1nfern0's answer (when PipeWire is working), you can use the following Bash script to toggle between A2DP (high fidelity playback, with the microphone disabled) and mSBC (for usage as a headset, with the microphone enabled):


# Toggle your bluetooth device (e.g., Bose Headphones) between A2DP mode (high-fidelity playback with NO microphone) and HSP/HFP, codec mSBC (lower playback quality, microphone ENABLED)
function tbt {
    current_mode_is_a2dp=`pactl list | grep Active | grep a2dp`
    card=`pactl list | grep "Name: bluez_card." | cut -d ' ' -f 2`

    if [ -n "$current_mode_is_a2dp" ]; then
        echo "Switching $card to mSBC (headset, for making calls)..."
        pactl set-card-profile $card headset-head-unit-msbc
        echo "Switching $card to A2DP (high-fidelity playback)..."
        pactl set-card-profile $card a2dp-sink

The above script is an adaptation from: https://bbs.archlinux.org/viewtopic.php?pid=1973205#p1973205


I was having issues (So many that I don't even know where to start).

What worked for me:

After following all the steps above, I submitted on Terminal the following:

To restart Pulse Audio:

mv ~/.config/pulse/ ~/.config/pulse.old

systemctl --user restart pulseaudio

mv ~/.config/pulse/ ~/.config/pulse.old

pulseaudio --k && pulseaudio --start

To reinstall Pulse Audio:

sudo apt update

sudo apt install --reinstall -o Dpkg::Options::="--force-confmiss" pulseaudio

dpkg -L pulseaudio

rm $HOME/.config/pulse/*

Enabling Pipewire

systemctl --global --now enable pipewire{,-pulse}.{socket,service}

sudo systemctl --global --now enable pipewire{,-pulse}.{socket,service}

sudo systemctl --global --now enable pipewire pipewire-pulse

sudo systemctl --user --now enable pipewire pipewire-pulse

sudo systemctl --user --now enable pulseaudio.service pulseaudio.socket

Nuking pulseadio again:

sudo pkill pulseaudio

sudo /etc/init.d/bluetooth restart

I don't really know which one did the trick... but now after:

pactl info

I get:

Server String: /run/user/1000/pulse/native

Library Protocol Version: 35

Server Protocol Version: 35

Is Local: yes

Client Index: 155

Tile Size: 65472

User Name: *

Host Name: *

Server Name: PulseAudio (on PipeWire 0.3.58)

Server Version: 15.0.0

Default Sample Specification: float32le 2ch 48000Hz

Default Channel Map: front-left,front-right

Default Sink: bluez_output.90_98_38_0B_87_BD.a2dp-sink

Default Source: alsa_input.pci-0000_00_1b.0.analog-stereo

Cookie: 2b71:d622

And all of this work because now ubuntu settings shows AAC codec for the Bluetooth device.

Hope this helps someone...


I faced problem of Connection refuse

Connection failure: Connection refused
pa_context_connect() failed: Connection refused

I followed following modifed steps and was successful in replacing Pulseaudio with Pipewire

Step 1 : Add the PipeWire PPA

$ sudo add-apt-repository ppa:pipewire-debian/pipewire-upstream

Step 2 : Install the pipewire-audio-client-libraries package

$ sudo apt update
$ sudo apt install pipewire pipewire-audio-client-libraries

Step 3 : Install some additional libraries, to use a Bluetooth headset.

$ sudo apt install gstreamer1.0-pipewire libpipewire-0.3-{0,dev,modules} libspa-0.2-{bluetooth,dev,jack,modules} pipewire{,-{audio-client-libraries,pulse,media-session,bin,locales,tests}}

Step 4 : Reload the daemon in systemd

$ systemctl --user daemon-reload

Step 5 : Disable PulseAudio in Ubuntu

$ systemctl --user --now disable pulseaudio.service pulseaudio.socket

Step 6 : Start PipeWire and enable

$ systemctl --user --now enable pipewire pipewire-pulse

Step 7 : Command to ensure that PipeWire

$ pactl info

pactl info was giving me a connection refuse (after following step 9 from the accepted answer on Ubuntu 20.04 LTS). I fixed by using wireplumber instead of pipewire-media-session-service.

  • 1
    Could you elaborate? How did you 'use' it instead? What if you already ran the enable command for pipewire-media-session-service? May 21, 2022 at 23:36
  • 1
    Just downvoted this answer because it's not clear on how to install/enable and use wireplumber in Ubuntu 20.04
    – meetnick
    Nov 11, 2022 at 17:56
➜  / sudo systemctl --global --now enable pipewire{,-pulse}.{socket,service}
Failed to connect to bus: $DBUS_SESSION_BUS_ADDRESS and $XDG_RUNTIME_DIR not defined (consider using --machine=<user>@.host --user to connect to bus of other user)
➜  / sudo systemctl --global --now enable pipewire pipewire-pulse
Failed to connect to bus: $DBUS_SESSION_BUS_ADDRESS and $XDG_RUNTIME_DIR not defined (consider using --machine=<user>@.host --user to connect to bus of other user)
➜  / sudo systemctl --user --now enable pipewire pipewire-pulse
Failed to connect to bus: $DBUS_SESSION_BUS_ADDRESS and $XDG_RUNTIME_DIR not defined (consider using --machine=<user>@.host --user to connect to bus of other user)
➜  / sudo systemctl --user --now enable pulseaudio.service pulseaudio.socket
Failed to connect to bus: $DBUS_SESSION_BUS_ADDRESS and $XDG_RUNTIME_DIR not defined (consider using --machine=<user>@.host --user to connect to bus of other user)
➜  / 

i tried all of the above answers but i am still not getting mSBC codec

#bluez5.enable-sbc-xq = true #bluez5.enable-msbc = true #bluez5.enable-hw-volume = true #bluez5.enable-faststream = true

i have these enabled in the bluez-monitor.conf

available codecspactl info


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .