When I try to shutdown my machine using the normal shutdown menu it just logs off the current user and brings me back to the lightdm login window.
I have to open a terminal and execute "shutdown -h now" to shutdown my system. Any help?

EDIT: I noticed this behavior only occurs when I was previously switching users on my pc i.e. the 'guest-session' is still running in the background.

  • do you have RabbitMQ installed? May 9 '12 at 11:04
  • no. I don't have rabbitmq. May 9 '12 at 23:12
  • You can install RabbitMQ with "sudo apt-get install rabbitmq"
    – TenorB
    May 10 '12 at 22:57
  • Have you solved this issue?
    – pl1nk
    Jun 27 '12 at 23:19

The problem is with the multiple logged in users in your system. I used to experience the same problem. Solved it by a policy chane allowing logout even when multiple users are logged in. If you understand the implications(like lose of non-saved data, for other logged in users) of allowing such a thing, you could go ahead and do the same. It can be done as follows:

  1. sudo vi /etc/polkit-1/localauthority/50-local.d/usershutdown.pkla
  2. As content of that file, enter the following and save it:

    [Allow Shutdown]
    [Allow Restart]

Now restart your system and check if things are working as intended.

N.B: You could use any other editor of your choice to create that file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.