1

I am trying to connect my acer monitor to lenovo laptop for display using HDMI cable of acer monitor using this devise: https://www.amazon.in/Dell-DA100-USB-3-0-Multi-Adapter/dp/B00O0M46T0. It's not working. I can directly connect acer HDMI to the lenovo laptop, and it seem to work fine but with this multi adapter USB 3.0 it's not working. First, I thought there is some issue with the mutli-adapter, but I can connect my mouse or keyboard to the usb port of the multi-adapter and when connected to my laptop it works fine.So issue is with the HDMI port of the multi-adapter.

I searched for a solution, found this: https://www.synaptics.com/products/displaylink-graphics/downloads/ubuntu, so followed instructions here: https://www.synaptics.com/products/displaylink-graphics/downloads/ubuntu

I was able to install everything without any error. After this, I rebooted my system and inserted HMDI cable to USB 3.0 multi-adapter again to test, but still its not working.

Earlier on Ubuntu 20 I tested, I was having the same issue. Now I am running Ubuntu 21. Also, Ubuntu is my primary OS, I am not running any dual boot.

Output of lsb_release -a command:

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 21.04
Release:    21.04
Codename:   hirsute

Output of uname -a command:

Linux aamir-ThinkPad-T480 5.11.0-17-generic #18-Ubuntu SMP Thu May 6 20:10:11 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
5
  • From the manufacturer, this hardware requires proprietary software and proprietary drivers to work. The manufacturer only provides proprietary software and proprietary drivers for Windows. So the device is not going to work on any other operating system.
    – Nmath
    May 19, 2021 at 17:56
  • So, there is now way to make it work on ubuntu 21? Isn't there any free software to support it?
    – Aamir
    May 19, 2021 at 18:04
  • Unlikely if the hardware manufacturer doesn't open source their drivers and software
    – Nmath
    May 19, 2021 at 21:20
  • Is there any USB adapter in the market that actually works fine with ubuntu?
    – Aamir
    May 20, 2021 at 13:14
  • unfortunately it may be the problem in the adaptor, i am using the same adaptor and it doesnt work for both winidows 10 and ubuntu 20 (as mentioned in the other answer), i've updated the driver and displaylink, tried on different screens, ethernet and usb2.0 ports work, vga dont know, hdmi can detect screens but cant display on them
    – Daniel Lee
    May 22, 2022 at 16:24

1 Answer 1

0

This Synapics driver download (v5.4.1) worked for me for Ubuntu 20.04 https://www.synaptics.com/node/4036?filetype=exe

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .