I have this script (or rather a set of commands which has permission to execute) to enable two finger scrolling and two finger tap = right click The script is located in /home/gaurav/Multigesture/multigesture.

When I run the following command in terminal, two finger scrolling and two finger tap = right click start working. I have to run this command each time I boot my laptop.


So I put this command in the startup applications so that I dont have to run the command each time I boot but when I reboot two finger scrolling is not working, only two finger tap = right click works.

What could be the problem, If the command works fine from the terminal then how come it is working partially when i put it into startup applications.

Here is the content of the script

xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Two-Finger Scrolling" 8 1 xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Scrolling" 8 1 1 xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Pressure" 32 10 xinput set-int-prop "SynPS/2 Synaptics TouchPad" "Synaptics Two-Finger Width" 32 8

PS. the file which has all the commands (script's) name is multitouch


I came across this fix which works just fine for me and recognizes two fingers (scroll and right click). Just download this package -->


As per comments on the bug report, this package has worked for most of the multitouch touchpads including Acer. Three finger touch didn't work for me.

read comment #115 and #116 at https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/308191/+index?comments=all


You can make a script load at boot up by making it an init scripts. Here is a how-to: Ubuntu bootup howto

  • I think this is the same process that @Manish has suggested which doesn't seem to work. – Gaurav Butola Nov 15 '10 at 17:40

Not sure if this works either but

add this line to /etc/rc.local (before "exit 0"):


  • looks like /etc/rc.local doesn't run on the startup. – Gaurav Butola Nov 16 '10 at 10:46

Here is an howto for setting up scripts for touchpad: ubuntu community documentation EEE PC. The section on multi-touch alnswers your question on runnning scripts at boot.

  • That is the same thing I am doing mentioned there. – Gaurav Butola Nov 16 '10 at 10:56

Not sure if this works but

Copy the script to /etc/init.d/


sudo cp multitouch /etc/init.d/multitouch

And then update the script to work in runlevel 2345

sudo update-rc.d multitouch defaults

and then enable this command using rcconf

sudo rcconf

Select the multitouch options using space bar and hit OK

reboot the system

You might need to install the package rcconf

sudo apt-get install rcconf

Hope this works

This tutorial gives a better insight on how update-rc works. http://www.debuntu.org/how-to-manage-services-with-update-rc.d

Google for runlevels if you want to gain more knowledge.

  • :( when I put it into startup apps, command partially works but from the above mentioned method the script doesn't seem to run at all, whereas when I do sudo "/etc/init.d/multigesture" everything works fine. – Gaurav Butola Nov 15 '10 at 17:37
  • I added the answer. Check the sudo update-rc.d multitouch defaults command. – Manish Sinha Nov 17 '10 at 9:27

Maybe try a simple upstart startup script. Create a file in /etc/init with the .conf extension. In the file put:

start on started tty1

exec /home/gaurav/Multigesture/multigesture


Slowing the startup script maybe helps...

I've had a problem with conky because the xserver was not completely loaded when startup application started conky.

I resolved with:


sleep 10 && conky;

you sould just change conky with your script name (and path) :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.