I tried to compile and install SDL2 from https://wiki.libsdl.org/Installation. Then I tried to test a program, I got a program file missing error for libsdl2-2.0.so.0: Program file cannot be opened. Pretty normal. Google time! I did some stuff from here: https://stackoverflow.com/questions/29711336/libsdl2-2-0-so-0-cannot-open-shared-object-file. I was trying to fix my problem.

I suddenly got a can't find -lvulkan error from gcc(I was still trying to fix my program file errors). I forgot what I had just done, in my attempts to solve the libsdl2-2.0.so program file error. For now, I removed the -lvulkan, it still didn't work due to the .so file not being found.

Then I ran ldconfig in the terminal, it was a simple solve, then it was running, I have no idea what that does, found I need to do it from Google. SDL worked, but -lvulkan error persisted. SDL_CreateWindow() wasn't working now. It was giving no available video device error. It's probably because of OpenGL stuff from my Google research. You know what? Now, -lGL too doesn't work. No linking against OpenGL after doing whatever I did, probably caused by the same thing that caused Vulkan problems.

Any idea what I might have done? Why is this happening? I only ran a sudo command once for ldconfig, how can any other thing do anything at /usr? I did got problems with the trash in nautilus, seemed like it thought that deleted files still existed. It was fixed after a restart. I had used nautilus with sudo once, that's where it could have gone wrong but my trash was empty, so I surely didn't delete anything.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.