6

Hi all Im very new to linux and have just bult my first linux based computer and having some issues with my internal storage hdds.

I have one 18tb seagate connected to my adeptec pcie card via sas, and for some reason I cannot seem to eject it from the file tab and for some reason it shows up as a disk drive(see screen shot).hdd

Every time I try to eject it I get the following error:

Error ejecting/dev/sda:Command-line'eject'/dev/sda" exited with non-zero exit status1: eject:unable to eject, last error: inappropriate ioctl for device:

Error

Its a brand new drive and just been formatted so unsure what is going on.

Ive tried to eject in command line but get the same error.

Any help would be much appreciated

5

Only removable drives connected trough e.g. USB can be "ejected". After ejecting, they are not "seen" anymore by the OS, unless you plug them out then back in again.

This is different from an internal disk, like your disk attached through you card. These remain visible to the system. At most, you can disconnect, i.e., "unmount" the file system such that that is closed and not accessible. It is also normal that an additional internal volume, be it a different partition, or a partition on another drive, that is not announced in the configuration file /etc/fstab, is shown as a drive in the left panel of the file manager. That allows you to connect to it, i.e. mount it, by clicking the icon.

2
  • 1
    Thanks for your response it makes sense. much appreciated. Just finding my gears with Linux. – dave.2 May 15 at 11:37
  • 1
    Sorry I upvoted it rather than ticking it as the answer. Thanks for the help, – dave.2 May 15 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.