2

Yesterday, May 14th, Ubuntu showed the availability of 21.04 on all my computers. I successfully upgraded a desktop and a server. For the last computer planned to upgrade today the option disappeared. It showed the availability of 21.04 yesterday but not today. Tried everything, update - upgrade - do-release-upgrade and dist-upgrade. nothing.. Did Canoncial pull back the 21.04 release again ?

In the updater the setting was "for any new version" , but found out that in /etc/update-manager/release-upgrades it was set to 'lts'. Weird, because I never changed that. Changed it to 'normal' Still not working...

16
  • I don't see it in changelogs.ubuntu.com/meta-release (which is why you box doesn't)... but I've not heard anything sorry. I do see it in changelogs.ubuntu.com/meta-release-development so -d will still work.. – guiverc May 15 at 9:54
  • How long ago did you change the release-upgrades file? I think the actual check is performed by apport. You could try running /etc/cron.daily/apport to see if it updates. – TuxInvader May 15 at 10:25
  • The same happened to me. Checked yesterday (May, 14th), the upgrade was available. I hesitated and checked again today, and it's not shown anymore. Weird. – Mrokii May 15 at 15:50
  • Unusual maybe, I don't see it as weird. I've not been watching release discussions, or release-upgrader bugs filed, but I'm betting a number of 20.10->21.04 bugs were being reported b/c of a condition that can be fixed; so it was disabled until that issue is resolved then it'll be re-opened.. but this is all guess. There will be a reason if for the 'delay' (and/or change). Groovy still has a couple of months of support left so I'd not worry. – guiverc May 15 at 22:24
  • May 16th sudo /etc/cron.daily/apport does not solve it. Isee it with -d but don't prefer the -d developer option as would prefer for normal upgrade. and 21.04 was said to be formally been released. My MB does not use UEFI, it's an older MB but works fine. wondering if Ubuntu had any dependencies to show the upgrade or not. It seems not an isolated case. (@Mrokki twice weird :-)). if it's not in the release log, why did it show up two days ago ? do-release-upgrade Checking for a new Ubuntu release No new release found. – Debugging May 15 at 23:56
5

Formal release refers to the ISO release only. Upgrades are documented as being opened after the actual release, eg. on 20.04 or a LTS release, upgrades occur only after the release of the 20.04.1 ISO, and that can be days-weeks after the actual ISO release. We're still only barely weeks after 21.04 ISO, and as documented there have been issues with britney or the build infrastructure that has meant a backlog & delays on fixes hotting main repositories..

Upgrades from Ubuntu 20.10 to Ubuntu 21.04 are not enabled as it is possible for some systems to end up in an unbootable state if they use EFI version 1.10 - bug 1925010. Release upgrades will be enabled once an updated version of shim is available which is compatible with EFI version 1.10.

The original shim bug (documented in the release notes as the reason upgrade was first disabled) has been fixed, so the upgrade was turned on... then various users upgrading were filing bugs reporting failure to boot.. another shim problem was detected & thus the upgrade tap was turned off again (to prevent more users upgrading & failing to boot...).

Decisions are made based on users experiences (& bug reports) & the moment a pattern emerges that can be easily fixed (delay upgrade until fixed) - it was enacted & upgrades disabled again (offer disappeared).. No one currently sees the option to upgrade

This is the file your machine checks to see if an upgrade is available

or if you attempt upgrade with -d option it looks instead at this file

The Ubuntu Release Team control what appears in these files

FYI: It's again SHIM issues impacting other versions & makes... though that's just one issue being watched & part of the decision. This answer is based on discussions in #ubuntu-release in IRC

1
1

After reading the comment done by guiverc I tried "sudo update-manager -d", and that did find the upgrade. Although then the updater tells me that this is still a development release, which seems weird to me.

1

The 21.04 upgrade became available again through the regular means of dist upgrades (software updater or sudo do-release-upgrade without the -d flag).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.