I'm trying to connect to my server with sftp. The server is working just fine. I connected to it from FileZilla. Then I was able to connect to it using Dolphin by just typing in the address: sftp://username:password@domain/. This worked and I was even able to transfer files.

However, I would like to create a directory to save this for future use, so that I don't have to type that in every time. It seems that "Add Network Directory" uses ftp instead of sftp, making it so that I cannot connect to the server. I can find no way to make it use sftp, is there a way to do this?

Every time that I try to connect, it asks for the password, I enter it, and then I get this error:

  Server replied:
  530 Non-anonymous sessions must use encryption.
  Do you want to retry?

2 Answers 2


If it's your server and you have SSH access, than maybe setup a SSH connection instead and use fish://username@remotehost as the URI in dolphin.

There is a big difference between SFTP (FTP over SSH) vs FTPS which is FTP over TLS. It gets more complicated because FTPS has an implicit and explicit mode, implicit uses a dedicate port and connects using TLS, while the explicit mode uses the normal ftp port and switches to TLS with startTLS command.

Looking at the source: https://github.com/KDE/dolphin/blob/c836cf010c12858a7f3a4943c06f9de2b9f31a14/doc/index.docbook#L609

The docs imply the dolphin supports SFTP and FISH, both of which use SSH. I can find no mention of FTPS, so perhaps it doesn't support that?

  • I made a typo, I used sftp to connect successfully. But in the Add Network Folder -> FTP there is not option for sftp, so it just kept refusing my connection. I assume there must be a way to use sftp for that. However, I used ssh instead and it worked, so thanks a lot for the help.
    – Lee Morgan
    May 15, 2021 at 9:31

You probably did something wrong. I've successfully created SFTP folder to my server by these steps

screenshot 1

screenshot 2

By the way, you probably shouldn't use fish:// protocol, it is fallback protocol for ssh servers which don't support sftp and it's not fast. Default sshd servers confugured with sftp enabled by default.

  • Yep, the answer above gave me the way to do that. I was using FTP in the first step.
    – Lee Morgan
    May 15, 2021 at 14:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.