0

Normal boot works (sort of) while in recovery mode hangs before the login.

Recently I've had a problem with Xfce desktop not loading except through recovery mode, following this:

  1. While in GRUB and on the recovery menu entry press E to edit the menu entry.

  2. Remove the nomodeset parameter from the line starting with linux.

  3. Press Ctrl + X to boot with the modified kernel command line.

It resolves the issue, except unlike before it doesn't fully load the Xfce desktop environment. Do I have other options to get back what worked before?

1
  • Welcome to Ask Ubuntu. Please don't put SOLVED, FIXED, RESOLVED etc. In the question title. The green check mark ✅ is sufficient. – user68186 May 19 at 2:14
0

from recovery mode of the kernel correctly installed, the one with 'ii' initials for both linux-modules and linux-modules-extra, check dpkg -l | grep linux-modules I've reinstalled the one being actually used. to check which one is it:

uname -r

to reinstall (in my case linux-modules-extra of the used kernel had 'ic' initials):

sudo apt install --reinstall linux-modules-extra-*kernel name*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.