1

After installing Ubuntu 20.04 several months ago I noticed that my computer is running more slowly than before. It takes anywhere from 30 seconds to one minute to launch Chrome browser. Pages load more slowly. Other programs function more slowly. So I ran memtest86 from a restart, and it froze. I have attached a photo of the memtest screen but I don't have the technical expertise to understand the data. Please note the Test at 60% with the hash marks: it has been stuck at 60% for the last ten minutes and nothing else on the screen has changed since then. Please advise as to what I need to do to determine whether I have a problem with memory or other hardware, or if there is a firmware issue, etc. Thank you. Memtest86 at 12:49 on May 13, 2021

3
  • Boot your machine and show me free -h and sudo swapon -s and sudo lshw -C memory. Start comments to me with @heynnema or I'll miss them. – heynnema May 14 at 0:58
  • To be completely sure about your RAM sticks please run memtest from older LiveCDs like Ubuntu 12.04 LTS. On my C2Ds with non-faulty hardware it runs well. – N0rbert May 14 at 11:44
  • I haven't seen your response to my request for more data... – heynnema May 14 at 14:22
2

If memtest freezes, you very likely have a hardware problem. It's probably your RAM, but there is no way to be sure.

If you did any overclocking, the first thing to try is to reset that to normal. Similar with RAM timings: If you changed those, reverting them to factory defaults in the BIOS would be worth a try.

If you are sure you did none of that, it's time to replace the RAM. According to the memtest output, you seem to have a single bank of RAM, right? If it's more than one, you could try to remove part of the RAM (make sure the lower RAM banks are filled) and re-check; you might get lucky and find out which of the RAM modules is affected.

But first check if you maybe have an thermal problem: Check the temperature inside the PC case. Open it to see if all fans are spinning. Clean out the dust puppies (very carefully with a vacuum cleaner and if you have it, with compressed air in a can; or with a photo "rocket blower" if you have one).

HTH

18
  • I am not sure how many RAM banks I have. Here is a link to a photo I shot last week of the inside of my computer's case: 4shared.com/s/fRSJ14krdea . Can you advise whether I have one or two RAM banks? And if two, which one is the "lower RAM bank"? Thank you. – Scott Semel May 13 at 21:37
  • 1
    It seems to be only one alright. It's that small circuit board standing upright near the power supply / hard disk, next to that bunch of brown cables. The little white plastic lever on its left side will unlock it. But it might be a bit difficult to get it out with that metal box in the lower right corner in the way. Check your PC's manual what type of RAM you need. – HuHa May 13 at 21:58
  • 1
    If your PC works normally for a while (20-30 min) when you first switch it on and after that starts getting slower and eventually halts / crashes, this would indicate a thermal problem. Check if the fans are spinning and if there is air flow near them. There is one in the power supply unit (the hamster cage on the bottom left), and probably one more in that black plastic duct on the top right. – HuHa May 13 at 22:01
  • 1
    @ScottSemel You can't mix/match DDR3 and DDR4 DIMMS. You must use the style that your motherboard supports. – heynnema May 14 at 14:17
  • 1
    @N0rbert Tell me that you're running on newer hardware than that :-) Are you sure that there's really not a RAM problem on those case examples? memtest freezing is normally an indication that there's a RAM problem. Was this when using AMD processors? AMD processors are very fussy about RAM compatibility. – heynnema May 14 at 14:26
0

There is a known bug on memtest86: bug #1876157 I ran into the same problem, and memtest86 hung at exactly the same place on ubuntu 21.04. I ran "memtester 6650M" on 8 Gig system to mostly test memory. It ran 5 cycles with no errors. The 6650M left just enough room for the O/S.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.