0

I completed the do-release upgrade, and when I rebooted, for a while all worked, but the network manager was down.

So I reinstalled the RealTeak wifi driver.

Now, the whole terminal is not responding. I run commands like sudo network-manager start, and hit enter, and nothing happens. It goes to a new line as if loading, then hangs there.

When I run neofetch, much less information comes up. Only OS, Host, Kernel and Uptime. The rest has disappeared.

enter image description here

And, after running neofetch, the terminal crashes (again, hanging).

I cannot use the internet via WiFi, and the ethernet is not working (orange and yellow light at the port, and no recognition from Ubuntu). Also, everything is very slow, e.g. settings won't load for 30 secs. Bluetooth has crashed and appears to be totally broken.

How can I fix this? I cannot reinstall ubuntu without a network connection? Is there some recovery mode I might use?

2
  • 1
    You can try a previous kernel in recovery mode. And if it works fine in a 21.04 live session then, as usual, the best and fastest solution for failed release upgrades is always a fresh install. May 13 at 15:26
  • The problem was in fact caused by the wifi adapter, which had a corrupt driver. Running in recovery mode appeared to bring the Ethernet back on, then I just unplugged the adapter (before booting), and its been ok since. Will have to remove all traces and perhaps buy another wifi adapter!
    – apkg
    May 14 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.