I'm using Ubuntu 12.04 with two hard drives.

The second drive is set to mount to /home/myuser/DATA and it mounts OK. However gnome shows a 'Removable Devices' item in notification area which lists my hard drive with the unmount button.

How do I make Ubuntu to treat the second hdd like the system one, without suggesting me to unmount it in the notification area?

  • I'm also interested in the answer to this question, as I have the same problem with LUKS encrypted drives. – zigg May 11 '12 at 19:01

The solution is to change the mount point to /mnt/"something". Modify your fstab and it shouldn't show the unmount option any longer.

Then you may bind mount it to the directory you want:

UUID=your_uuid_here /mnt/DATA ext4       defaults        0       2
/mnt/DATA             /home/yrogirg/DATA   none bind 0 0
  • Can't test this, because my LUKS partition is mounted as / and cannot be relocated. – zigg May 18 '12 at 18:24
  • hm @zigg I haven't tried that yet, because I don't need mounting to /mnt either. But what if mounting to /mnt and then bind mount to / ? – Yrogirg May 19 '12 at 15:36
  • It worked for me, To Do, I've edited your answer a bit to include bind mount fstab line. and there is a typo, it should be "UUID" – Yrogirg May 19 '12 at 15:48

It looks like the GNOME people are already aware of this; see this bug:


(For now, though, it's sufficiently annoying to me that I'd like to see a workaround, hence the bounty.)


Modify your /etc/fstab adding a line as follows:

UUID=[your second hdd UUID] /               ext3    errors=remount-ro,user_xattr 0       1

You may want to change "/" with a different mount point or ext3 with the correct file system.

  • how does it supposed to solve the problem? Is it because of 1? or user_xattr? – Yrogirg May 16 '12 at 16:54
  • Just try and tell me if it works... It's a combo between those options. – jasmines May 16 '12 at 19:21
  • 1
    It doesn't work for LUKS devices. My encrypted partition, which is already on / and already has an fstab entry with a pass number of 1 (FWIW: the pass number is used by fsck to determine the order of filesystem checks at boot time), still shows as a removable drive. I'm not totally sure what user_xattr was supposed to do for this anyway. – zigg May 16 '12 at 23:14
  • 2 more hints. 1) Try with pysdm (it's a fstab GUI editor). 2) looking in /sys/block/ I saw two files that could be help: /sys/block/sda/removable (it contains 0) and /sys/block/sr0/removable (it contains 1). – jasmines May 17 '12 at 4:12
  • 1
    I'm afraid that we (you) will have to wait for the next release in the GNOME 3 series, that is scheduled for 24 September 2012. However you could try to go with the live development version (currently in a very early 3.5.1) to see if the problem is being handled: news.softpedia.com/news/… – jasmines May 18 '12 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.