1

I recently created a dual-boot on my Asus ROG STRIX Scar 15 w/ NVIDIA RTX 3080 GPU. I had some issues installing Ubuntu 20.04.2 LTS, but finally got it to work, however, my GPU is not coming up when I look for it in Terminal.

Looking at the ubuntu-drivers devices I get:

:~$ ubuntu-drivers devices
== /sys/devices/pci0000:00/0000:00:01.1/0000:01:00.0 ==
modalias : pci:v000010DEd0000249Csv00001043sd00001602bc03sc00i00
vendor   : NVIDIA Corporation
driver   : nvidia-driver-460 - third-party non-free recommended
driver   : nvidia-driver-460-server - distro non-free
driver   : nvidia-driver-465 - third-party non-free
driver   : xserver-xorg-video-nouveau - distro free builtin

I tried purging nvidia, reinstalling, rebooting, etc. but nothing seems to work. When I go into my Ubuntu settings the GPU that is shown is: llvmpipe (LLVM 11.0.0, 256 bits).

When I try lspci | grep VGA I get:

01:00.0 VGA compatible controller: NVIDIA Corporation Device 249c (rev a1)
05:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Device 1638 (rev c5)

Additionally, when I try nvidia-smi I get "NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running."

When I try nvidia-settings I get:


ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system


(nvidia-settings:5634): GLib-GObject-CRITICAL **: 15:28:57.073: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 15:28:57.075: PRIME: No offloading required. Abort
** Message: 15:28:57.075: PRIME: is it supported? no

When I type prime-select query the only item is nvidia (which used to show nothing but ondemand).

I tried downloading from the nvidia site with the .run file, I tried autoinstall, I tried prime-select intel then reboot then back to prime select-nvidia, but nvidia-smi and nvidia-settings still fails.

Please help!

Additional Info:

When I try sudo lshw -C video I get

*-display UNCLAIMED       
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller cap_list
       configuration: latency=0
       resources: iomemory:f80-f7f iomemory:fc0-fbf memory:fb000000-fbffffff memory:f800000000-fbffffffff memory:fc00000000-fc01ffffff ioport:f000(size=128) memory:fc000000-fc07ffff
  *-display UNCLAIMED
       description: VGA compatible controller
       product: Advanced Micro Devices, Inc. [AMD/ATI]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:05:00.0
       version: c5
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
       configuration: latency=0
       resources: iomemory:fc0-fbf iomemory:fc0-fbf memory:fc10000000-fc1fffffff memory:fc20000000-fc201fffff ioport:d000(size=256) memory:fc500000-fc57ffff

which doesnt seem right to me?

My monitor will also not work in Linux, which also seems to have something to do with the GPU.

8
  • Start by disabling Secure Boot in UEFI. May 10 at 21:53
  • It has nothing to do with the OS, it's all in UEFI ("BIOS") settings. May 10 at 22:18
  • Sorry I'm new to this, I disabled Secure boot. Do I need to purge and reinstall again?
    – Oliver
    May 10 at 22:19
  • It is now stuck at the Asus startup screen, after I selected Ubuntu from the boot options.
    – Oliver
    May 10 at 22:21
  • Then reinstall using the latest release, 21.04. May 10 at 22:22
1

I fixed this by first reinstalling Ubuntu 21.04. (I knew this was a step in the right direction because my monitor finally started working!)

Once Ubuntu 21.04 was installed, I first tried reinstalling the nvidia drivers using the Software & Updates, then rebooting to disable secure boot. When I disabled secure boot, it still wouldn't boot, so I re-enabled secure boot, did prime-select intel, then purged Nvidia similar to this (https://forums.developer.nvidia.com/t/newly-installed-drivers-are-not-found-when-nvidia-smi-is-called/82686/7).

I rebooted, I disabled secure boot, it finally booted. However, when I tried to install the Nvidia drivers using Software & Updates it would not boot again with Secure Boot disabled.

I discovered I had to install the Nvidia drivers using terminal ubuntu-drivers autoinstall

Thus, the procedure was

  1. Install Ubuntu 21.04
  2. prime-select intel
  3. purge nvidia drivers
sudo apt-get remove --purge '^nvidia-.*'
sudo apt-get install ubuntu-desktop
sudo apt-get --purge remove "*cublas*" "cuda*"
sudo apt-get --purge remove "*nvidia*"
sudo add-apt-repository --remove ppa:graphics-drivers/ppa
sudo rm /etc/X11/xorg.conf
sudo apt autoremove
sudo reboot
  1. Reboot, disable secure boot in BIOS
  2. Reinstall Nvidia as such
sudo ubuntu-drivers devices
sudo ubuntu-drivers autoinstall
sudo reboot 

I have yet to re-enable secure boot as I am scared that it will not boot and I will have to go through this process again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.