Logging in via the shell accessed through Ctrl+Alt-F1 and logging in as guest via the graphical user interface work 0O

When I try to log into my standard user account via the graphical interface, the screen flashes to black for a couple of seconds and bumps me back to a pristine login screen. Entering a wrong password for my user account yields the standard error message - my user account and credential verification seem to be OK.

I suppose that my individual graphics configuration causes problems ... I'm not sure how to reset that. I've tried stopping the UI via

sudo service lightdm stop


sudo nvidia-xconfig

and restarted the UI

sudo service lightdm start

to no avail.

My workstation has a Nvidia GeForce 560-448 graphics card. I've tried getting this fixed with the latest Nvidia 64-bit drivers (cURL'ed from the official website), that is 295.49 and the latest beta driver 302.07.

Anybody have an idea how to get this fixed? Your help is appreciated :)

  • I've installed GDM via 'sudo apt-get install gdm' and set it as default display manager vs. lightdm After a reboot I can log into my user account via GDM's old style login screen. Even though I'm happy this lets me get back to work, I'd love to know why lightdm is acting flaky and how to resolve this properly. May 8, 2012 at 10:26
  • 1
    This should help you diagnostic the problem - askubuntu.com/questions/65852/cannot-login-to-my-user-account .
    – Web-E
    May 8, 2012 at 10:41
  • 1
    Thank you for the pointer. I've just set lightdm as display manager again with 'sudo dpkg-reconfigure lightdm'. I can log in via the standard login screen now. May 8, 2012 at 10:56

6 Answers 6


I've changed the display manager from the default LightDM to GDM by installing latter via sudo apt-get install gdm. With GDM set as new display manager (execute sudo dpkg-reconfigure gdm if you couldn't set GDM as display manager during installation), I could log in via the old-school graphical login screen it presented me with after a reboot.

Once logged in, I reset my display manager to LightDM by executing sudo dpkg-reconfigure lightdm. After another reboot, things were back to normal: I can log in via the distribution's standard login UI, now.

  • I tried the same thing, but ended up back at the login loop when I restored lightdm, so now I'm just using gdm and everything is okay. Close enough.
    – pettazz
    Feb 21, 2013 at 15:32

Check after 12.04 upgrade: can't log in although password is correct. At the bottom of question you'll see:

sudo rm /home/<username>/.Xauthority*
sudo apt-get install --reinstall xorg
sudo reboot

That worked perfectly to me.


This is weird.

I've been running 12.04 for awhile now (a few months) without issue. I haven't logged into the GUI in awhile (I typically shell in or use Webmin). Today, I tried to log into the machine via the GUI with my non-root account, it acts like it's trying to load up the desktop then bounces me back. I'm able to shell into the account without issue.

I created a new account and I can log in via the GUI, but the old account still doesn't work.

I stopped lightdm and started gdm and I was able to gain access into my old account via the GUI.

lightdm is probably choking on something...I've no idea what, since the account home directory of the old account is pretty empty, with the acception of hidden files. I suspect that lightdm is choking on a hidden file.

I was just going to leave it alone and continue to use gdm, but looked at the above possible solution.

Ran sudo rm /home/username/.Xauthority* and didn't reinstall xorg. I stopped gdm and started lightdm. Then I attempted to log into the old account again...with success!

sudo useradd -m username1
sudo passwd -m username1

This reset everything back to where I could log in again.


I had to create a new account username2 thru: sudo useradd -m username2 and set a sudo passwd username2 for it. then I login on it thru lightdm create another account username3 (so it have stuff like sudoers working, what username2 dont have) then I copy all stuff from /home/username to /home/username3 thru "midnight commander" mc then sudo chown username3:username3 /home/username3 -R (it wont chown folders contents that are symlinked, whatchout!) when I login on username3 it seems to be all ok now!

I did several tests, even tried to clean the home path (rename/bkp and use a copy of a newly created home), but I couldnt login on username, so my guess is there is some outside configuration that prevents the username to work but username3 and username2 can login on lightdm. May be at /etc?

I must say also that when the system froze and I forced a hard restart (what made me not be able to login on lightdm), my ctrl+alt+f1 that always gave me a black screen, now is working!! so I wonder what is the configuration file to fix because I believe if I run some standard command I may loose access to my text console ctrl+alt+f1... ?

  • I have to say that I did: sudo dpkg-reconfigure gdm, what indeed let me login with my username account! but after that I cannot return to lightdm it still prevents me from login, so I will remain on gdm... I wonder if this horrible crash happens on gdm, what will I do if I cant find a fix for lightdm :? May 28, 2012 at 2:05
  • I have to say also that, I lost ctrl+alt+f1 again, screen is blanked... just to complete my initial post... May 28, 2012 at 2:24

Check your .xsession-errors file in your home directory for any errors after logging in via Ctrl + Alt + F1.

In my case, I had bad characters in my .profile file from my Git installation (my bad).

After I removed it, I was able to login via the login GUI.

Comment #18 at this question helped me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.