I have two 2TB disks. I am installing Ubuntu 12.04 using the alternate version of the server cd. On the partitioning page I have done my partitioning as follows

/dev/sda1 - 32 MB - bios_grub
/dev/sda2 - 50 GB -raid device
/dev/sda3 - 8 GB -raid device
/dev/sda4 - Balance full GB - raid device

/dev/sdb1 - 32 MB - bios_grub
/dev/sdb2 - 50 GB -raid device
/dev/sdb3 - 8 GB -raid device
/dev/sdb4 - Balance full GB - raid device

After this I have setup raid devices
/dev/md0 for /(/dev/sda2 + /dev/sdb2) for / ext4
/dev/md1 for swap( /dev/sda3 + /dev/sdb3)for swap
/dev/md2 for /home(/dev/sda4 + /dev/sdb4)for /home ext4

The installation finishes it shows that it is installing grub to /dev/sda and /dev/sdb. But once the system reboots it falls into grub rescue> mode. on doing ls I can not see the md devices only hd once.

I also tried booting into rescue mode with the install cd and doing grub-install /dev/sda and /dev/sdb. What am I doing wrong ? Why is grub2 not detecting the raid revices ?

UPDATE: I just did the same steps with Ubuntu 10.04 and it worked perfectly fine. I wiped out the RAID and partitions and everything and did it from scratch. I think the issue is with Ubuntu 12.04 and the way it partitions 2 TB disks

closed as too localized by psusi, Eric Carvalho, Basharat Sialvi, rɑːdʒɑ, Thomas Ward Apr 18 '13 at 5:53

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Voting to close since question appears to be abandoned and will not be answered. – psusi Apr 17 '13 at 17:58

I'm not sure if this is the correct answer but I tend to put /boot outside LVM or software RAID system. The latest grub2 boot loader might support this (in certain configuration) but this is not completely guarantee.

Perhaps you could investigate this idea.

From Wikipedia, about mdadm:

Since support for MD is found in the kernel, there is an issue with using it before the kernel is running. Specifically it will not be present if the boot loader is either (e)LiLo or GRUB legacy. It may not be present for GRUB 2. In order to circumvent this problem a /boot filesystem must be used either without md support, or else with RAID1. In the latter case the system will boot by treating the RAID1 device as a normal filesystem, and once the system is running it can be remounted as md and the second disk added to it. This will result in a catch-up, but /boot filesystems ought to be small.


Does your RAID volumes have metadata version 0.9? They don't contain enough information for grub to, p.e., recognize if the entire disk is used for raid or just the last partition on it.

It's a check they newly built into grub. I had a similar problem and we're working through a bug-report: https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/999076

Not the answer you're looking for? Browse other questions tagged or ask your own question.